Bug 429939 - selinux enabled in kickstart causes system to panic on first boot
selinux enabled in kickstart causes system to panic on first boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Alpha
  Show dependency treegraph
 
Reported: 2008-01-23 16:41 EST by Bill Peck
Modified: 2008-01-28 17:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 17:26:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (18.99 KB, text/plain)
2008-01-24 15:48 EST, Bill Peck
no flags Details

  None (edit)
Description Bill Peck 2008-01-23 16:41:11 EST
Description of problem:
if selinux is set to enforcing in the kickstart file the system will panic on
the first boot after install

Version-Release number of selected component (if applicable):
rawhide-20080123

How reproducible:
Everytime

Steps to Reproduce:
1. do a kickstart install with selinux --enforcing 
  
Actual results:

Loading ata_piix module
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 19
scsi0 : ata_piix
scsi1 : ata_piix
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
ata2.00: ATAPI: SAMSUNG DVD-ROM SD-616E, F501, max UDMA/33
ata2.00: configured for UDMA/33
scsi 1:0:0:0: CD-ROM            SAMSUNG  DVD-ROM SD-616E  F501 PQ: 0 ANSI: 5
ata_piix 0000:00:1f.2: MAP [ P0 -- P1 -- ]
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 19
scsi2 : ata_piix
scsi3 : ata_piix
ata3: SATA max UDMA/133 cmd 0xfe00 ctl 0xfe10 bmdma 0xfea0 irq 19
ata4: SATA max UDMA/133 cmd 0xfe20 ctl 0xfe30 bmdma 0xfea8 irq 19
ata3.00: ATA-6: WDC WD2500JD-75HBB0, 08.02D08, max UDMA/133
ata3.00: 488281250 sectors, multi 8: LBA48 
ata3.00: configured for UDMA/133
scsi 2:0:0:0: Direct-Access     ATA      WDC WD2500JD-75H 08.0 PQ: 0 ANSI: 5
sd 2:0:0:0: [sda] 488281250 512-byte hardware sectors (250000 MB)
sd 2:0:0:0: [sda] Write Protect is off
sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
sd 2:0:0:0: [sda] 488281250 512-byte hardware sectors (250000 MB)
sd 2:0:0:0: [sda] Write Protect is off
sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
 sda: sda1 sda2
sd 2:0:0:0: [sda] Attached SCSI disk
modprobe used greatest stack depth: 848 bytes left
Waiting for driver initialization.
Loading dm-mod module
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.12.0-ioctl (2007-10-02) initialised: dm-devel@redhat.com
Loading dm-mirror module
Loading dm-zero module
Loading dm-snapshot module
Loading sd_mod module
Making device-mapper control node
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  Found volume group "VolGroup00" using metadata type lvm2
Activating logical volumes
  2 logical volume(s) in volume group "VolGroup00" now active
Trying to resume from /dev/VolGroup00/LogVol01
No suspend signature on swap, not resuming.
Creating root device.
Mounting root filesystem.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Setting up other filesystems.
Setting up new root fs
no fstab.sys, mounting internal defaults
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
audit(1201108529.567:2): enforcing=1 old_enforcing=0 auid=4294967295
Unable to load SKernel panic - not syncing: Attempted to kill init!
ELinux Policy. M
Comment 1 Daniel Walsh 2008-01-24 13:48:27 EST
This looks like anaconda did not do the installation correctly.
Comment 2 Bill Peck 2008-01-24 14:03:43 EST
I looked a little closer at the logs and found this:

/usr/sbin/load_policy:  Can't load policy:  No such file or directory
Comment 3 Bill Nottingham 2008-01-24 14:46:19 EST
Do you have the anaconda installation logs?
Comment 4 Bill Peck 2008-01-24 15:48:06 EST
Created attachment 292854 [details]
anaconda log
Comment 5 Chris Lumens 2008-01-28 15:33:54 EST
There were a couple days where we were having problems with selinux during
installation.  Is this error message and bug report fixed today?
Comment 6 Will Woods 2008-01-28 16:22:47 EST
Works for me in today's rawhide, and with the f9alpha.2 pre-release tree. Bill?
Comment 7 Bill Peck 2008-01-28 16:45:52 EST
Yup.  I verified it works where it didn't work before.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.