Bug 429943 - ustr tests failing on ia64
ustr tests failing on ia64
Product: Fedora
Classification: Fedora
Component: ustr (Show other bugs)
ia64 Linux
high Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
Reported: 2008-01-23 16:50 EST by Doug Chapman
Modified: 2008-02-13 13:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-13 13:59:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-01-23 16:50:24 EST
Description of problem:
I first thought this might be the same as BZ 402511 but looks like we have yet
another set of errors on ia64.  Luckily not as many but it still prevents
building which prevents building libsemanage.

 -=> ASSERT (!ustr_io_putfilename(&s2, "/dev/full", "wb")) failed in (tst) from 
299 ctst_11_io.c.
/bin/sh: line 3:  8205 Aborted                 ./$tst
FAIL: ctst_11_io

 -=> ASSERT (!ustr_io_putfilename(&s2, "/dev/full", "wb")) failed in (tst) from
299 octst_11_io.c.
/bin/sh: line 3:  8210 Aborted                 ./$tst
FAIL: octst_11_io

 -=> ASSERT (!ustr_io_putfilename(&s2, "/dev/full", "wb")) failed in (tst) from 
301 tst_11_io.c.
/bin/sh: line 3:  8355 Aborted                 ./$tst
FAIL: tst_11_io

 -=> ASSERT (!ustr_io_putfilename(&s2, "/dev/full", "wb")) failed in (tst) from
301 otst_11_io.c.
/bin/sh: line 3:  8360 Aborted                 ./$tst
FAIL: otst_11_io

I plan on digging more deeply into these errors but would appreciate any
feedback you might be able to provide.  I imagine you don't have easy access to
ia64 hardware.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 James Antill 2008-01-23 19:36:47 EST
 It looks to me like you might have the /dev mode settings wrong. There was a
bug in mock where /dev/full wasn't being created (looks like you have that
problem). So I put this test in:

    FILE *filechk = fopen("/dev/full", "wb");

    if (!filechk) /* some versions of mock didn't have it */
      ret = EXIT_FAILED_OK;

...at a guess the above is actually creating a normal file called "full" in
/dev, when you do the build. Jesse Keating has a fix for mock, that creates the
correct /dev file ... apart from that, fixing the perms. so the above test fails
will make it skip it ... and as a last resort (assuming the above is the only
thing failing in the ustr build), just don't run the make check part.
Comment 2 Doug Chapman 2008-01-25 10:29:43 EST

I think you are correct.  I tried building this outside of mock and it builds
just fine.  I have not had a chance to take a look at the mock environment to
confirm but your explenation appears to fit.  Is the updated version with the
check you made in CVS?  If so I will grab it and give it a try.  Or, if you do a
normal rawhide build my scripts will pick it up since I am doing an rsync of all
src rpm's every couple of days (we don't have koji set up for ia64 just yet).


- Doug
Comment 3 James Antill 2008-01-25 14:45:57 EST
 The workaround is in ustr-1.0.3-2, I just re-tried it on rawhide and mock is
happy there, see:

Comment 4 Doug Chapman 2008-02-13 13:59:57 EST
ustr- is now building cleanly for me in koji (we now have an ia64 koji
server).  Closing this bug.


- Doug

Note You need to log in before you can comment on or make changes to this bug.