This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 429969 - Rhel 5 xen crashes during boot in a vm
Rhel 5 xen crashes during boot in a vm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks: 514491
  Show dependency treegraph
 
Reported: 2008-01-23 19:57 EST by Eli Collins
Modified: 2010-11-09 08:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 12:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Serial console output (6.91 KB, text/plain)
2008-01-23 19:57 EST, Eli Collins
no flags Details
cpu info (2.64 KB, text/plain)
2008-01-23 19:58 EST, Eli Collins
no flags Details
dmidecode info (23.38 KB, text/plain)
2008-01-24 12:51 EST, Eli Collins
no flags Details
guest cpuinfo (1.14 KB, text/plain)
2008-01-24 16:20 EST, Eli Collins
no flags Details
guest dmidecode info (12.78 KB, text/plain)
2008-01-24 16:20 EST, Eli Collins
no flags Details
serial console output (rhel 5.1) (7.26 KB, text/plain)
2008-01-25 03:35 EST, Eli Collins
no flags Details

  None (edit)
Description Eli Collins 2008-01-23 19:57:50 EST
Description of problem: 

Rhel 5.1 Xen does not boot in a VMware workstation 6 vm on some AMD cpus. I do
not see this issue on core 2 cpus.

How reproducible: 100%, you can't boot.

If you install Rhel 5.1, enable virtualization packages, on reboot into xen
after the install, xen crashes early in loading dom0. I've uploaded serial
console ouput with the crash info and cpuinfo.
Comment 1 Eli Collins 2008-01-23 19:57:50 EST
Created attachment 292720 [details]
Serial console output
Comment 2 Eli Collins 2008-01-23 19:58:32 EST
Created attachment 292721 [details]
cpu info
Comment 3 Stephen Tweedie 2008-01-24 09:38:49 EST
First, this is a RHEL-5 GA kernel log, not RHEL-5.1.  But more importantly...

I notice that the cpu flags include "svm".  Is vmware really virtualising the
hardware virtualisation capabilities of the CPU?

But beyond that, we seem to be oopsing in dmi_string(), in the dmi decoder. 
We'd probably need to see full dmidecode  output and boot logs from a non-xen
kernel in the same virtual environment to get a handle on what's going wrong in
the dmi handling, if that's the problem.
Comment 4 Eli Collins 2008-01-24 12:51:15 EST
Created attachment 292830 [details]
dmidecode info
Comment 5 Eli Collins 2008-01-24 12:55:34 EST
Sorry about that, wires crossed, you're right, it's rhel 5.

The uploaded cpuinfo is *host* cpuinfo, not what the guest sees. dmidecode info
from the host is attached. The host is rhel 4 u6 64-bit btw.

I can upload guest cpuinfo/dmidecode info from booting into rhel 5 w/o xen if
that's useful. 
Comment 6 Eli Collins 2008-01-24 16:20:19 EST
Created attachment 292858 [details]
guest cpuinfo

cpuinfo obtained from the guest (booting w/o xen)
Comment 7 Eli Collins 2008-01-24 16:20:57 EST
Created attachment 292859 [details]
guest dmidecode info

dmidecode obtained from the guest (booting w/o xen)
Comment 8 Daniel Berrange 2008-01-24 16:36:34 EST
RHEL-5.0 contains the Xen 3.0.3 hypervisor. In RHEL-5.1 this was updated to Xen
3.1.0 to fix numerous hypervisor bugs, so attempting to debug problems with the
3.0.3 hypervisor isn't really a productive exercise. Please retry using the
RHEL-5.1 packages in the guest, and try to capture another serial console -
which should show xen-3.1.0 /  kernel-xen-2.6.18-53.el5
Comment 9 Eli Collins 2008-01-25 03:35:16 EST
Created attachment 292915 [details]
serial console output (rhel 5.1)
Comment 10 Eli Collins 2008-01-25 03:37:24 EST
Uploaded serial output from rhel 5.1 xen. Seems to be a different error, now
it's an unhandled pf in dom0.    
Comment 11 Andrew Jones 2010-06-22 12:58:30 EDT
This is old and unlikely still a problem. Closing.

Note You need to log in before you can comment on or make changes to this bug.