Bug 430016 - replication should use ssl
replication should use ssl
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: freeipa10 429034
  Show dependency treegraph
 
Reported: 2008-01-24 01:52 EST by Chandrasekar Kannan
Modified: 2012-03-27 03:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-01-24 01:52:22 EST
Ticket #116 (new defect)

Opened 2 months ago
replication should use ssl
Reported by: 	kmacmill 	Assigned to: 	kmacmill
Priority: 	major 	Milestone: 	release-1
Component: 	documentation 	Version: 	
Keywords:
Comment 3 Rob Crittenden 2008-01-31 15:49:08 EST
It looks like Karl added SSL to replication. The CA is copied to the replica and
we setup the agreement with:

nsds5replicatransportinfo: SSL

I think this is ready for testing.
Comment 4 Yi Zhang 2008-04-04 19:05:17 EDT
qa verified. bug closed

build: 4-4-08 daily build

ldap access log msg as below: 

[04/Apr/2008:15:44:42 -0700] conn=8 fd=69 slot=69 SSL connection from
172.16.142.140 to 172.16.142.161
[04/Apr/2008:15:44:42 -0700] conn=8 SSL 256-bit AES
[04/Apr/2008:15:44:42 -0700] conn=8 op=0 BIND dn="cn=replication
manager,cn=config" method=128 version=3
[04/Apr/2008:15:44:42 -0700] conn=8 op=0 RESULT err=0 tag=97 nentries=0 etime=0
dn="cn=replication manager,cn=config"
[04/Apr/2008:15:44:42 -0700] conn=8 op=1 SRCH base="" scope=0
filter="(objectClass=*)" attrs="supportedControl supportedExtension"

Note You need to log in before you can comment on or make changes to this bug.