Bug 430017 - memberOf attribute should not be replicated
memberOf attribute should not be replicated
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: freeipa10 429034
  Show dependency treegraph
 
Reported: 2008-01-24 01:53 EST by Chandrasekar Kannan
Modified: 2012-03-27 03:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add memberof to the exclusion list (905 bytes, patch)
2008-02-18 15:18 EST, Rob Crittenden
no flags Details | Diff

  None (edit)
Description Chandrasekar Kannan 2008-01-24 01:53:36 EST
Ticket #117 (new defect)

Opened 2 months ago

Last modified 1 month ago
memberOf attribute should not be replication
Reported by: 	kmacmill 	Assigned to: 	kmacmill
Priority: 	major 	Milestone: 	release-1
Component: 	ipa-server 	Version: 	
Keywords: 		Cc: 	
Description ¶

But the fractional replication setup makes this almost impossible - you must provide a list of attributes to replicate (which we can't have because of custom schema) rather than a list of attributes not to replicate.
Change History
2007-12-21 09:41:55 changed by kmacmill ¶

Turns out this is wrong - fractional replication is based on a list of attributes to *exclude*.
Comment 3 Rob Crittenden 2008-02-18 15:18:02 EST
Created attachment 295200 [details]
add memberof to the exclusion list
Comment 4 Rob Crittenden 2008-02-20 09:53:37 EST
Committed in changeset 646
Comment 5 Yi Zhang 2008-04-03 16:54:26 EDT
QA have a whole set of memberOf test cases. The functional testing of memberOf
will automatic cover this scenario, therefore this bug is closed.

 

Note You need to log in before you can comment on or make changes to this bug.