Bug 430031 - Review use of Remove links in webUI
Review use of Remove links in webUI
Status: CLOSED WONTFIX
Product: freeIPA
Classification: Community
Component: WebUI (Show other bugs)
1.0
All Linux
low Severity low
: v2 release
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 02:13 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 13:02:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-01-24 02:13:34 EST
Ticket #162 (new enhancement)

Opened 1 month ago

Last modified 1 month ago
Review use of "Remove" links in webUI
Reported by: 	davido 	Assigned to: 	rcritten
Priority: 	minor 	Milestone: 	release-1
Component: 	ipa-gui 	Version: 	
Keywords: 	useability 	Cc: 	
Description ¶

At present the fields that can take multiple values have "Remove" links next to them. I'm not sure that this adds any value (you can just focus on the field and press Delete) and it also slows down data entry if you use the keyboard to Tab between fields.

This link also appears next to the Common Names field, but if there is only one Common Name, you can't remove it.
Change History
2007-12-10 12:55:32 changed by rcritten ¶

    * milestone changed from milestone-6 to release-1.

There has to be a remove link for the multi-valued fields because otherwise after adding one you could never remove it.

I found a way to remove the "Remove" link from the first entry so that one isn't displayed for single-valued fields. The thing is that a Remove link is never displayed for that first entry which can be a tad annoying.

It will require changes to the tgexpandedform TG module.

I'm going to move this to release-1 for now as it doesn't affect code completeness.

Note You need to log in before you can comment on or make changes to this bug.