Bug 430035 - Provide facility for inspecting details of service principals in webUI
Summary: Provide facility for inspecting details of service principals in webUI
Status: CLOSED ERRATA
Alias: None
Product: freeIPA
Classification: Retired
Component: WebUI (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Rob Crittenden
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: freeipa10 429034
TreeView+ depends on / blocked
 
Reported: 2008-01-24 07:17 UTC by Chandrasekar Kannan
Modified: 2012-03-27 07:18 UTC (History)
5 users (show)

Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chandrasekar Kannan 2008-01-24 07:17:05 UTC
Ticket #172 (new enhancement)

Opened 2 weeks ago

Last modified 2 weeks ago
Provide facility for inspecting details of service principals in webUI
Reported by: 	davido 	Assigned to: 	rcritten
Priority: 	minor 	Milestone: 	release-1
Component: 	ipa-gui 	Version: 	
Keywords: 		Cc: 	simo, kmacmill
Description ¶

In the results list of "Find Service Principals", it would be good if you could click any of the results to display principal information. At present you just get a basic "host/service" list.
Change History
2008-01-07 08:28:12 changed by rcritten ¶

    * milestone changed from milestone-6 to release-1.

2008-01-07 13:59:44 changed by rcritten ¶

    * cc set to simo, kmacmill.

What sorts of details are there to display?
2008-01-11 11:07:06 changed by rcritten ¶

As part of ticket #176 it is possible to click on a service principal and bring up details but the only details are the hostname and the service (ldap/host/etc).

This was done to make deleting a principal easier. I hope at some point to be able to add back in retrieval.

Comment 3 Rob Crittenden 2008-02-06 16:31:36 UTC
One can again click on a principal but there is just nothing really there to show.

I need to know what you want to see.

Comment 4 Suzanne Hillman 2008-02-08 21:30:05 UTC
Well, right now there appears to be no way to delete service principals; I would
at least expect clicking to give the option for deletion.

Comment 5 Suzanne Hillman 2008-02-08 21:32:09 UTC
However, reading the initial info in the bug, it looks like not being able to
click one out of a list is itself a bug (right now trying this gives 500
internal errors); should I open a new bug for this?

Comment 6 Rob Crittenden 2008-02-08 22:40:40 UTC
It is an unpackaged file. I'll fix that first, then you'll see that on the page
that renders you'll have a way to delete service principals.

Comment 7 Rob Crittenden 2008-02-08 22:50:35 UTC
Install principalshow.kid

diff -r 8fe51bd4120d -r 4a9980ee7ab5 ipa-server/ipa-gui/ipagui/templates/Makefile.am
--- a/ipa-server/ipa-gui/ipagui/templates/Makefile.am   Fri Feb 08 17:34:23 2008
-0500
+++ b/ipa-server/ipa-gui/ipagui/templates/Makefile.am   Fri Feb 08 17:49:49 2008
-0500
@@ -29,6 +29,7 @@ app_DATA =                    \
        policylayout.kid        \
        principallayout.kid     \
        principallist.kid       \
+       principalshow.kid       \
        principalnewform.kid    \
        principalnew.kid        \
        usereditform.kid        \


Comment 8 Rob Crittenden 2008-02-08 22:51:07 UTC
Committed in changeset 635

Comment 9 Yi Zhang 2008-05-28 17:14:31 UTC
QA Verified on May 28, 2008 (Yi)

Build used: May 28, 2008 (i386)


Note You need to log in before you can comment on or make changes to this bug.