Bug 430036 - in Find Service Principals, searching on 'http' will not give results for 'HTTP'
in Find Service Principals, searching on 'http' will not give results for 'HTTP'
Status: CLOSED WONTFIX
Product: freeIPA
Classification: Community
Component: WebUI (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: freeipa10 429034
  Show dependency treegraph
 
Reported: 2008-01-24 02:18 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 10:11:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-01-24 02:18:31 EST
Ticket #175 (new defect)

Opened 2 weeks ago

Last modified 2 weeks ago
in Find Service Principals, searching on 'http' will not give results for 'HTTP'
Reported by: 	shillman 	Assigned to: 	rcritten
Priority: 	minor 	Milestone: 	release-2
Component: 	ipa-gui 	Version: 	
Keywords: 		Cc: 	simo
Description ¶

in Find Service Principals, searching on 'http' will not give results for 'HTTP'; looks like a case sensitivity problem. Searching on 'HTTP' _will_ work, FWIW.
Change History
2008-01-09 13:47:40 changed by shillman ¶

In the Web UI 9and likely the CLI)
2008-01-09 14:15:33 changed by rcritten ¶

    * cc set to simo.

This is because the schema marks krbPrincipalName with caseExactIA5Match.

Simo, is this a good thing or a bad thing? Is there a workaround?
2008-01-09 14:34:07 changed by simo ¶

    * priority changed from major to minor.
    * milestone changed from milestone-6 to release-2.

The principals right now are case sensitive for MIT, so there is no other way but to mark this attribute as such. This may change in future (perhaps), but right now we have to cope with it, it depends on the KDC.

Note You need to log in before you can comment on or make changes to this bug.