Bug 430056 - Executing system-config-firewall throws exception
Executing system-config-firewall throws exception
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 04:26 EST by Johno Crawford
Modified: 2008-01-24 09:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 09:03:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for NCDeviceList.py (764 bytes, patch)
2008-01-24 08:21 EST, Johno Crawford
no flags Details | Diff

  None (edit)
Description Johno Crawford 2008-01-24 04:26:54 EST
Description of problem:
When launching system-config-firewall from cli the following exception is thrown;

Traceback (most recent call last):
                                    File "/usr/sbin/lokkit", line 79, in <module>
     if not ui.run(config):
                             File "/usr/share/system-config-firewall/fw_tui.py",
line 261, in run
                     self.init(config)
                                        File
"/usr/share/system-config-firewall/fw_tui.py", line 115, in init
                                 for dev in NCDeviceList.getDeviceList():
                                                                           File
"/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 306, in
getDeviceList
             __DVList.load()
                              File
"/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 103, in load
                                       profilelist =
netconfpkg.NCProfileList.getProfileList()
              NameError: global name 'netconfpkg' is not defined


Version-Release number of selected component (if applicable):
[johno@hellface ~]$ uname -a
Linux hellface.com 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:36 EST 2007 x86_64
x86_64 x86_64 GNU/Linux

[johno@hellface ~]$ rpm -qa system-config-firewall
system-config-firewall-1.0.12-3.1.fc8

How reproducible:
Every time.

Steps to Reproduce:
1. Execute the command system-config-firewall via terminal.
  
Actual results:
system-config-firewall bails with the following error; NameError: global name
'netconfpkg' is not defined

Expected results:
Presented with a lovely cli menu.

Additional info:
Attempted to reinstall many packages, deps etc. to no avail.
Comment 1 Thomas Woerner 2008-01-24 05:13:55 EST
This is a bug in system-config-network, which has been resolved in updates.
Please update the package system-config-network.
Comment 2 Johno Crawford 2008-01-24 05:24:35 EST
Thank you for the fast response!

[root@hellface ~]# yum update system-config-network
Setting up Update Process
Could not find update match for system-config-network
No Packages marked for Update
[root@hellface ~]# rpm -qa system-config-network
system-config-network-1.4.7-1.fc8

Executing system-config-firewall is still throwing the same exception..
Comment 3 Thomas Woerner 2008-01-24 06:39:22 EST
Is your system-config-network-tui package also version 1.4.7-1.fc8?
Comment 4 Johno Crawford 2008-01-24 06:45:27 EST
Certainly is;

[johno@hellface ~]$ rpm -qa system-config-network-tui
system-config-network-tui-1.4.7-1.fc8
Comment 5 Thomas Woerner 2008-01-24 07:18:16 EST
There seems to be another system-config-network problem.
Reassigning to system-config-network.
Comment 6 Johno Crawford 2008-01-24 08:21:55 EST
Created attachment 292794 [details]
Proposed patch for NCDeviceList.py

Attaching proposed patch..
Comment 8 Johno Crawford 2008-01-24 09:02:42 EST
Thank you, good sir!

Note You need to log in before you can comment on or make changes to this bug.