Bug 430063 - system hung with htb QoS
Summary: system hung with htb QoS
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: iproute   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-24 10:48 UTC by Kapetanakis Giannis
Modified: 2008-02-15 11:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 11:01:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg, lspci, QoS, iptables, modprobe.conf (70.00 KB, application/x-tar)
2008-01-24 10:48 UTC, Kapetanakis Giannis
no flags Details

Description Kapetanakis Giannis 2008-01-24 10:48:19 UTC
Hi,

I've setup QoS on my ftp server to limit outgoing traffic. Apparently the server
stops responding (no output no keyboard) in an unpredictable manner. Sometimes it 
takes an hour, sometimes up to 4 days for the system to hung.

I have included an attachment with my QoS startup script, dmesg output,
lspci -vvv, iptables that interact with QoS.

I'm also receiving this quite often:
Jan 15 12:23:17 ftp kernel: e1000: eth0: e1000_clean_tx_irq: Detected Tx Unit Hang
Jan 15 12:23:17 ftp kernel:   Tx Queue             <0>
Jan 15 12:23:17 ftp kernel:   TDH                  <2a>
Jan 15 12:23:17 ftp kernel:   TDT                  <17>
Jan 15 12:23:17 ftp kernel:   next_to_use          <17>
Jan 15 12:23:17 ftp kernel:   next_to_clean        <2a>
Jan 15 12:23:17 ftp kernel: buffer_info[next_to_clean]
Jan 15 12:23:17 ftp kernel:   time_stamp           <5798144>
Jan 15 12:23:17 ftp kernel:   next_to_watch        <2d>
Jan 15 12:23:17 ftp kernel:   jiffies              <57988ef>
Jan 15 12:23:17 ftp kernel:   next_to_watch.status <0>
Jan 15 12:23:19 ftp kernel: e1000: eth0: e1000_clean_tx_irq: Detected Tx Unit Hang

Today for the first time (after applying options to e1000 driver in
modprobe.conf) I got a kernel panic:

BUG: unable to handle kernel paging request at virtual address a0379120
EIP: 0060: [<c05db2dc>] Not Tainted VLI
EIP is at ip_rcv+0x286/0x4ba
Kernel panic - not syncing: Fatal exception in interrupt

This is what I wrote on paper cause there wasn't logged anywhere.
Usually it hungs without a kernel panic.

System in Fedoca Core 8 up2date
2.6.23.9-85.fc8PAE
2x Intel(R) Xeon(TM) CPU 3.20GHz
4G RAM

Without the QoS loaded system never hungs. It must be related to this. However
the e1000 error I'm receiving must have to do with the e1000 driver. I've seen
this bug in the past that's why I tried to apply the options in modprobe.conf

any help will be appreciated
thanx in advance 

Giannis

Comment 1 Kapetanakis Giannis 2008-01-24 10:48:19 UTC
Created attachment 292781 [details]
dmesg, lspci, QoS, iptables, modprobe.conf

Comment 2 Marcela Mašláňová 2008-02-15 09:30:24 UTC
I was looking for this problem on the Internet and this kernel message was
mentioned with network card, router etc. This could be capabilities problem of
network card or the driver, because they mentioned problems after changing value
of upload/download.

The type of network card could help me. 

Comment 3 Kapetanakis Giannis 2008-02-15 10:51:09 UTC
The card is an Intel Corporation 82546GB Gigabit Ethernet Controller.

By the way this bug was fixed by disabling TSO
/usr/sbin/ethtool -K eth0 tso off

regards
Giannis

Comment 4 Marcela Mašláňová 2008-02-15 11:01:31 UTC
Nice.

I'm closing bug as notabug,because that's not iproute's problem.


Note You need to log in before you can comment on or make changes to this bug.