This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 430068 - directives cannot be overridden in inherited kickstart
directives cannot be overridden in inherited kickstart
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 06:35 EST by Rahul Sundaram
Modified: 2013-03-13 01:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 17:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-01-24 06:35:18 EST
Description of problem:

While creating live cd's, I inherit a ks file and try to override the repo
option to point to a local mirror which doesn't work. 

Actual results:

It ignores the repo configuration in the main ks file and uses the repo option
in the base inherited ks file

Expected results:

Capability to override any ks directives
 
Additional info:

I suspect other directives like selinux are not being honored too. It would be
very useful to me, if I had flexibility to override any of the ks directives in
the main ks file after inheriting them for the purpose of creating custom spins
of Fedora and RHEL.
Comment 1 Chris Lumens 2008-01-24 10:30:30 EST
The repo command is special because it can be given multiple times in a single
kickstart file.  Every time the repo command is seen, another repo object is
constructed and appended to a list.  I bet you've got both the base file's repos
and the second file's repos included.

What does your code look like?
Comment 2 Rahul Sundaram 2008-01-25 03:17:15 EST
Yes. I have repository configurations in both the files. Is there a way to set a
priority to a particular repository? 
Comment 3 Chris Lumens 2008-01-28 17:45:45 EST
You can use repo --priority=
Comment 4 Rahul Sundaram 2008-02-22 09:56:47 EST
That works. Thank you. please ensure that this option is well documented. If all
other directives can be overridden, feel free to close this bug. 

Note You need to log in before you can comment on or make changes to this bug.