Bug 430085 - need a top level rpm meta package that installs everything
need a top level rpm meta package that installs everything
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: freeipa10 429034
  Show dependency treegraph
 
Reported: 2008-01-24 09:15 EST by Chandrasekar Kannan
Modified: 2012-03-27 03:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 03:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-01-24 09:15:15 EST
right now the installation is like

yum install ipa-server ipa-admintools ipa-client bind caching-nameserver

for someone that wants to install everything. 

Why wouldn't we have a top-level meta package like this

  yum install ipa ( that installs everything )

Maybe when we are at this, can we also create something like,

  yum install ipa-dns ( includes bind and caching-nameserver)
Comment 1 Rob Crittenden 2008-01-24 16:40:47 EST
This is not really correct.

For the server you just need to install ipa-server. This will pull in ipa-python
and ipa-admintools.

ipa-client is not needed on the server.

bind and/or caching-nameserver is optional though if desired we can add it to
the ipa-server requires.

On a client you just need to install ipa-client and it will pull in the things
it needs.

So I don't think a meta package is needed, or am I missing something?
Comment 4 Chandrasekar Kannan 2008-02-08 14:39:10 EST
>>For the server you just need to install ipa-server. 
>> This will pull in ipa-python
>> and ipa-admintools. ipa-client is not needed on the server.

Actually we are having to do ipa-client-install as well to get
stuff like ssh working which is a primary usecase for ipa. 

>> On a client you just need to install ipa-client 
>> and it will pull in the things it needs

no we need ipa-client and ipa-admintools

So, can we do this ?

(1) for ipa server - yum install ipa-server ( should pull in client,admintools,
bind ,caching-nameserver ). If the admin doesn't need to use  bind, he doesn't
have to use --setup-bind. So, I would rather pull down all the rpms ahead of time. 


(2) for ipa client - yum install ipa-client ( this should pull down client,
admintools in one shot ).

Does that help ?
Comment 5 Rob Crittenden 2008-02-11 19:40:41 EST
I have added ipa-client as a Requires on ipa-server.

I won't add ipa-admintools as a requirement for ipa-client because the average
user is not going to need the admin tools (and won't have permission to run most
of them).

Simo and I agree that we don't want to impose bind on users since we don't
require a DNS server to do an installation.
Comment 6 Chandrasekar Kannan 2008-04-04 08:38:04 EDT
yum install ipa-server does bring in ipa-client and admintools. 
I guess thats the only change here. 

verified.

Note You need to log in before you can comment on or make changes to this bug.