This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 430087 - RFE: Anaconda needs to rename "advanced" to "assisted" partitioning mode and add real advanced mode
RFE: Anaconda needs to rename "advanced" to "assisted" partitioning mode and ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 09:20 EST by Valent Turkovic
Modified: 2008-03-17 14:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 13:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2008-01-24 09:20:20 EST
Description of problem:
Currently if you go to manual partition of an empty hard drive anaconda "guides"
you in sorting the order of partitions - no matter if you want anaconda's help
you don't.

I believe that real advanced mode needs to let you make and sort the order of
partitions in the way you want and current advanced mode should be renamed to
"assisted mode" or "guided mode".
There can be a check box in advanced mode that gives you this option while
creating partitions - something like "let fedora (or anaconda) guide you in
partition creating".

Currently in anaconda you can't make partition and sort then in the way you want
- and that seams really strange especially because fedora users are powerusers
and less newbies who need the assistance in ordering partitions in the optimal
order.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2008-01-29 11:46:43 EST
Order of partitions is not relevant in the real world and hasn't been for the
better part of a decade.   And we're not really interested in more paths to
having partitioning do things.
Comment 2 Valent Turkovic 2008-03-17 05:28:01 EDT
Ok, just make it do less things. Let users make partitions in the way they want
it and not in some arbitrary and non-open way, or non-straightforward.
When I create partitions I don't see why they are ordered in a way that is not
logical for me. Please correct that or explain in the installer the choices it
makes during partitioning. 
Comment 3 Chris Lumens 2008-03-17 10:43:09 EDT
Most users really don't care about making partitions at all, much less
specifying an exact ordering for partitions.  If you really care, you can always
drop to the shell, partition your disk with parted, and then use the custom
partitioning screen to assign mount points to the partitions you made.
Comment 4 Valent Turkovic 2008-03-17 11:39:47 EDT
Ok so you won't add real advanced more, but you still didn't resolve first part
of my RFE so I'm reopening it.

"Anaconda needs to rename "advanced" to "assisted" partitioning mode"
because real advanced more suggests full user power not guided partitioning by
anaconda
Comment 5 Lubomir Kundrak 2008-03-17 13:45:45 EDT
Valent: Please note that this would involve changes to documentation and break
translated strings with no benefit to the user at all.
Comment 6 Valent Turkovic 2008-03-17 14:37:24 EDT
ok, you are right.

Note You need to log in before you can comment on or make changes to this bug.