Bug 430113 - autofs unable to parse cifs map entry
autofs unable to parse cifs map entry
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
http:///
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 11:36 EST by Jeffrey Moyer
Modified: 2008-06-16 23:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 23:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Moyer 2008-01-24 11:36:54 EST
Description of problem:

mount string works with file: but not with program:

[root@home etc]# rpm -q autofs
autofs-5.0.1-31.x86_64

[root@home etc]# uname -a
Linux home.cs.siue.edu 2.6.23.8-34.fc7 #1 SMP Thu Nov 22 20:39:56 EST 2007
x86_64 x86_64 x86_64 GNU/Linux

[root@home etc]# tail -n 1 /var/log/messages
Jan 23 18:44:39 home automount[7567]: parse_mount: parse(sun): failed to expand
map entry

[root@home etc]# cat /etc/auto.homes
#! /bin/bash

echo "-fstype=cifs,dom=campus.siue.edu,credentials=/home/gbartho/credentials.txt
://ebserver-11.ac.siue.edu/2\$"

exit 0

[root@home etc]# date
Wed Jan 23 18:51:27 CST 2008
[root@home etc]# 

Version-Release number of selected component  if applicable :
autofs-5.0.1-31.x86_64

How reproducible:
100%
Comment 1 Ian Kent 2008-01-24 11:53:37 EST
You need to double escape the $ in this because $ is a special
character (macro indicator) and the echo (or the shell, I'm
not sure which) removes the escape.

Ian
Comment 2 Gregory Lee Bartholomew 2008-01-24 12:03:33 EST
I'll try that. Also, it sounds like something that should be included with an
example under "man 5 autofs"->"Executable Maps" to show exactly how many
backslashes to use in the common case where the share name ends with a $.

gb

(In reply to comment #1)
> You need to double escape the $ in this because $ is a special
> character (macro indicator) and the echo (or the shell, I'm
> not sure which) removes the escape.
> 
> Ian
> 

Comment 3 Gregory Lee Bartholomew 2008-01-24 12:19:18 EST
It worked! Double escaping the dollar sign (i.e. "\\$") solved the problem.

Thanks,
gb
Comment 4 Bug Zapper 2008-05-14 11:17:07 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2008-06-16 23:00:12 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.