Bug 430203 - RCS data files wrongly identified as audio files
Summary: RCS data files wrongly identified as audio files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-25 07:42 UTC by Deji Akingunola
Modified: 2009-03-24 13:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 13:25:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample rcs file causing issues (10.24 KB, application/x-gzip)
2008-01-25 15:36 UTC, Deji Akingunola
no flags Details

Description Deji Akingunola 2008-01-25 07:42:32 UTC
Description of problem: I've got a 300G external drive containing a bunch of RCS
files named like 'filename.ftn,v' among other various kinds of data file
(there's no single audio file on the disk). Since yesterday, when I plugged it
in, rhythmbox fires up and begins to load up the RCS files into it library,
nautilus too now sports a bar on its top right corner asking me to 'Open
Rhythmbox Music Player'. Codeina also open up an says "The application
"Rythmbox-metadata" requires a plugins to open files of type application/x-ar
decoder"


Version-Release number of selected component (if applicable):rhythmbox-0.11.4-4.fc9


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bastien Nocera 2008-01-25 11:20:58 UTC
Cold you please attach a gzipped version of one of those files, and quote the
version numbers of shared-mime-info, rhythmbox, and the gstreamer packages?

Comment 2 Deji Akingunola 2008-01-25 15:36:17 UTC
Sample file attached, running updated rawhide;
[deji@logos ~]$ rpm -q shared-mime-info
shared-mime-info-0.23-2.fc9
[deji@logos ~]$ rpm -q rhythmbox
rhythmbox-0.11.4-4.fc9
[deji@logos ~]$ rpm -q gstreamer
gstreamer-0.10.15-1.fc9
gstreamer-0.10.15-1.fc9

PS: codeina have now also added comment, "application "Rhythmbox-metadata"
requires the following plugin: application/x-gzip decoder". I'm not sure which
files are causing that as rhythmbox doesn't come up again now.

Comment 3 Deji Akingunola 2008-01-25 15:36:56 UTC
Created attachment 292950 [details]
sample rcs file causing issues

Comment 4 Deji Akingunola 2008-01-25 15:44:56 UTC
More info,
My .xsession-errors is filled with messages as;
>>
(rhythmbox:3168): RhythmDB-WARNING **: attempt to use same location in multiple
entry types

(rhythmbox:3168): RhythmDB-WARNING **: attempt to use same location in multiple
entry types
..
..
<<
and
>>
Rhythmbox-Message: Missing plugin:
gstreamer|0.10|rhythmbox-metadata|application/x-ar
decoder|decoder-application/x-ar (ignoring)
Rhythmbox-Message: All missing plugins are blacklisted, doing nothing
..
..
<<

and a couple of lines saying,
>>(rhythmbox-metadata:4929): GStreamer-WARNING **: pad mpegaudioparse0:src
returned caps which are not a real subset of its template caps
<<


Comment 5 Bastien Nocera 2008-03-26 12:47:43 UTC
Could you please test with the current rawhide? I can't reproduce the problem here.

Comment 6 Deji Akingunola 2008-04-09 05:16:15 UTC
With rhythmbox-0.11.5-7.fc9.x86_64, rhythmbox does not automatically start
anymore when I plug in the usb drive. However, if I start rhythmbox after the
disk is plugged, it immediately starts to populate the playlist with those RCS
files.

Comment 7 Bug Zapper 2008-05-14 04:53:01 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Bastien Nocera 2009-03-24 13:25:37 UTC
This works fine in rhythmbox 0.12.0 from rawhide, closing.


Note You need to log in before you can comment on or make changes to this bug.