Bug 430210 - Benchmarks for b43 - BCM4318
Benchmarks for b43 - BCM4318
Status: CLOSED DUPLICATE of bug 413291
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 05:01 EST by Jonathan Steffan
Modified: 2008-04-09 22:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 10:03:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Steffan 2008-01-25 05:01:56 EST
Description of problem:
Just some benchmarking data. I'm sick of my card performance sucking.

[jon@damaestrojr ~]$ dd if=/dev/zero of=/home/jon/test.img bs=1024 count=1048576
1048576+0 records in
1048576+0 records out
1073741824 bytes (1.1 GB) copied, 87.1328 s, 12.3 MB/s

Wired: kernel-2.6.23.9-85.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x: 
test.img                                      100% 1024MB  10.8MB/s   01:35    

real    1m38.579s
user    0m18.033s
sys     0m17.340s

Wireless: kernel-2.6.23.9-85.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x: 
test.img                                           1%   10MB  88.5KB/s 3:15:29 ETA
Killed by signal 2.

real    2m7.620s
user    0m0.839s
sys     0m0.291s

Wired: 2.6.23.14-107.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x:
test.img                                      100% 1024MB  10.1MB/s   01:41    

real    1m41.808s
user    0m18.321s
sys     0m17.643s


Wireless: 2.6.23.14-107.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x: 
test.img                                       36%  374MB   1.6MB/s   06:52 ETA
Killed by signal 2.

real    4m7.868s
user    0m14.910s
sys     0m14.681s

Wired: 2.6.23.14-115.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x:
test.img                                      100% 1024MB  10.7MB/s   01:36    

real    1m36.066s
user    0m18.144s
sys     0m18.193s

Wireless: 2.6.23.14-115.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x:
test.img                                        1%   11MB  93.1KB/s 3:05:43 ETA
Killed by signal 2.

real    2m4.585s
user    0m0.619s
sys     0m0.310s

2.6.23.14-107 seems to give the best performance, but 1.6MB/s still sucks.
Comment 1 John W. Linville 2008-01-25 10:03:19 EST

*** This bug has been marked as a duplicate of 413291 ***
Comment 2 Jonathan Steffan 2008-01-25 14:41:03 EST
Hmmm.

2.6.23.14-107 is not working with 802.11b APs, but works great with 802.11g APs.
Comment 3 Jonathan Steffan 2008-01-25 14:41:54 EST
05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g]
802.11g Wireless LAN Controller (rev 02)
Comment 4 Jonathan Steffan 2008-02-13 02:28:08 EST
Wired: 2.6.23.15-137.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.12:
test.img                                      100% 1024MB  10.9MB/s   01:34    

real    1m40.475s
user    0m18.532s
sys     0m17.693s

Wireless: 2.6.23.15-137.fc8
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x:
test.img                                       27%  283MB   1.3MB/s   09:37 ETA
Killed by signal 2.

real    3m42.484s
user    0m10.191s
sys     0m8.585s
Comment 5 Levente Farkas 2008-02-17 13:38:12 EST
the same speed problem for me with kernel-2.6.23.15-137.fc8
Comment 6 Jonathan Steffan 2008-02-22 02:50:44 EST
Wireless: 2.6.23.15-137.fc8
This is with using the latest recommended firmware and b43-fwcutter-011
[jon@damaestrojr ~]$ time scp test.img 192.168.0.x:
test.img                                      100% 1000MB   1.4MB/s   11:50    

real    11m57.563s
user    0m33.097s
sys     0m26.788s
Comment 7 Jonathan Steffan 2008-04-09 22:27:53 EDT
Wireless: 2.6.24.4-64.fc8
[jon@damaestrojr ~]$ scp test.img 192.168.0.x:
test.img                                      100% 1000MB   1.9MB/s   08:54

Good work, performance has been improving/staying steady.

Note You need to log in before you can comment on or make changes to this bug.