Bug 430211 - ImportError: No module named firstboot_module_window
ImportError: No module named firstboot_module_window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-boot (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-01-25 05:16 EST by Andrew Farris
Modified: 2008-03-02 19:47 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.2.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 19:47:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
system-config-boot-traceback (6.41 KB, text/plain)
2008-01-25 05:16 EST, Andrew Farris
no flags Details

  None (edit)
Description Andrew Farris 2008-01-25 05:16:28 EST
It appears the cloned bug below has reappeared, but the requires is in place so
its not quite the same issue.

system-config-boot fails to run after fresh rawhide install, 25 jan 2008

Component: system-config-boot
Version: 0.2.17
Summary: TB4303b6e5 boot_gui.py:30:<module>:ImportError: No module named
firstboot_module_window

Traceback (most recent call last):
  File "/usr/share/system-config-boot/system-config-boot.py", line 80, in <module>
    import boot_gui
  File "/usr/share/firstboot/modules/boot_gui.py", line 30, in <module>
    from firstboot_module_window import FirstbootModuleWindow
ImportError: No module named firstboot_module_window


Currently installed:
[root@cirithungol media]# rpm -q --requires system-config-boot
/bin/sh  
config(system-config-boot) = 0.2.17-1.fc8
firstboot  
pygtk2  
python2  
rhpl >= 0.6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
usermode >= 1.36

[root@cirithungol media]# rpm -q firstboot
firstboot-1.91-1.fc9

[root@cirithungol media]# rpm -q system-config-boot
system-config-boot-0.2.17-1.fc8

+ This bug was initially created as a clone of Bug #169394 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050915
Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
Running system-config-boot without the firstboot package installed dies with
this error message: 

Component: system-config-boot
Version: 0.2.9
Summary: TB2106918e firstboot_gui_window.py:11:?:ImportError: No module named
firstboot_module_window

Traceback (most recent call last):
  File "/usr/share/system-config-boot/system-config-boot.py", line 63, in ?
    import boot_gui
  File "/usr/share/firstboot/modules/boot_gui.py", line 32, in ?
    from rhpl.firstboot_gui_window import FirstbootGuiWindow
  File "/usr/lib/python2.4/site-packages/rhpl/firstboot_gui_window.py", line 11,
in ?
    from firstboot_module_window import FirstbootModuleWindow as FirstbootGuiWindow
ImportError: No module named firstboot_module_window

Local variables in innermost frame:
[ rest of message deleted ]

Installing firstboot-1.3.48-1.noarch.rpm fixes the problem.

Version-Release number of selected component (if applicable):
system-config-boot-0.2.9-1

How reproducible:
Always

Steps to Reproduce:
Make sure that firstboot is not installed, run system-config-boot as root

Additional info:

Installed packages:

firstboot-1.3.48-1
rhpl-0.174-1
system-config-boot-0.2.9-1

-- Additional comment from karsten@redhat.com on 2006-05-15 05:03 EST --
#rpm -ivh system-config-boot-0.2.11-1.2.i386.rpm
error: Failed dependencies:
        firstboot is needed by system-config-boot-0.2.11-1.2.i386

Fixed in -devel
Comment 1 Andrew Farris 2008-01-25 05:16:28 EST
Created attachment 292925 [details]
system-config-boot-traceback
Comment 2 Andrew Farris 2008-03-02 19:47:47 EST
This is currently fixed in:
firstboot-1.92-1.fc9.i386
system-config-boot-0.2.19-1.fc9.i386

Closing it up since s-c-boot is working.

Note You need to log in before you can comment on or make changes to this bug.