Bug 430245 - Xen: clock stopped after reboot save/restore
Xen: clock stopped after reboot save/restore
Status: CLOSED DUPLICATE of bug 426861
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2008-01-25 10:17 EST by Joe Orton
Modified: 2008-02-19 03:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-19 03:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2008-01-25 10:17:46 EST
Description of problem:
After rebooting the dom0, two guests have come back up without a ticking clock.
 dom0 is running xendomains so the guests were automatically save/restored over
the reboot.

[root@dhcp-0-208 ~]# date
Thu Jan 24 11:18:08 GMT 2008
[root@dhcp-0-208 ~]# date
Thu Jan 24 11:18:08 GMT 2008
[root@dhcp-0-208 ~]# date
Thu Jan 24 11:18:08 GMT 2008

This corresponds roughly to the time at which the guest state would have been saved:

reboot   system boot  2.6.18-53.1.6.el Thu Jan 24 11:20          (00:02)    
root     pts/4        vpn-6-11.fab.red Thu Jan 24 11:15 - down   (00:01)    
root     pts/0        vpn-6-11.fab.red Thu Jan 24 11:10 - down   (00:07)    

The guests seem otherwise fine; userspace is working albeit system calls act as
if time stands still (e.g. poll doesn't time out, nanosleep sleeps forever).

Version-Release number of selected component (if applicable):
dom0: 2.6.18-53.1.6.el5xen
guest: 2.6.18-53.el5xen

How reproducible:
This has affected 2/6 guests on the system; 4 of which were running RHEL 5.1
Comment 1 Joe Orton 2008-02-19 03:17:33 EST

*** This bug has been marked as a duplicate of 426861 ***

Note You need to log in before you can comment on or make changes to this bug.