Bug 430285 - Cannot synchronize USB-connected Palm Tungsten E2
Cannot synchronize USB-connected Palm Tungsten E2
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-25 14:42 EST by Kevin L. Mitchell
Modified: 2008-12-01 09:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-01 09:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kevin L. Mitchell 2008-01-25 14:42:35 EST
Description of problem:

I cannot synchronize my USB-connected Palm Tungsten E2 with the desktop.  If I
select the "usb:" device option in the "Device Settings" dialog of "gnome-pilot
Settings", I get a complaint about the visor module being loaded.  If I instead
select /dev/ttyUSB0 or /dev/ttyUSB1--both of which appear after I hit the
hotsync button on the pilot and disappear when the pilot gives up trying to hit
the desktop--all I get is two "gnome-pilot Settings" windows and no

Version-Release number of selected component (if applicable):


How reproducible:

Reproducible 100% of the time, so far as I can tell.

Steps to Reproduce:
1. Plug in a Palm Tungsten E2 to a USB port.
2. Configure gnome-pilot, either via Evolution or via the gnome pilot applet, to
connect to the pilot via USB.
3. Attempt to hotsync.
Actual results:

No synchronization occurs.

Expected results:

My palm pilot data should be synchronized with Evolution.

Additional info:

The ttyUSB* devices show up with clearly incorrect permissions:

crw-rw---- 1 root uucp 188, 0 2008-01-25 14:34 /dev/ttyUSB0
crw-rw---- 1 root uucp 188, 1 2008-01-25 14:34 /dev/ttyUSB1

I have had the exact same problem symptoms under Fedora Core 6, though so far as
I can remember, the permissions on the device(s) were correct.

I have tried using the "usb:" device for syncing, but I find I have to shut down
the hal daemon, which has configuration to load the visor module.  Even then,
visor gets loaded anyway when I hit the hotsync button.  Force-unloading visor
after that only stops gpilotd from popping up windows complaining about visor
being loaded; it still fails to synchronize.  Maybe I'm missing some simple
piece of configuration somewhere, but darned if I know what or where!

For the record, I also noticed that the release notes mention better bluetooth
support, including support for synchronizing a Palm Pilot via bluetooth...but I
can find no such configuration option in the gnome pilot settings.
Comment 1 John (J5) Palmieri 2008-02-27 09:56:31 EST
I just got my Treo to sync properly by installing this version of pilot-link
https://koji.fedoraproject.org/koji/buildinfo?buildID=35760.  I have no idea why
it hasn't been pushed to updates or testing yet so it might do other bad stuff.
 Can you try to see if that works?  After installing it I set my device to be
"usb:" and the type to be usb and it worked as soon as I hit the sync button.
Comment 2 Bug Zapper 2008-11-26 04:34:10 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 3 Matthew Barnes 2008-11-29 01:18:19 EST
Is this problem still present on Fedora 10 or later?
Comment 4 Kevin L. Mitchell 2008-11-29 19:06:56 EST
I don't know if the USB problem is present, but I can successfully synchronize via Bluetooth, so I'm happy.
Comment 5 Matthew Barnes 2008-12-01 09:55:32 EST
Thanks for responding.  Closing as WORKSFORME per comment #4.

Note You need to log in before you can comment on or make changes to this bug.