Bug 430333 - nautilus segfault starts using large percentage of cpu
nautilus segfault starts using large percentage of cpu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 03:57 EST by Roland Hermans
Modified: 2015-03-03 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.20.0-8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 19:25:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb backtrace of running nautilus process (1.95 KB, text/plain)
2008-01-26 03:57 EST, Roland Hermans
no flags Details
gdb backtrace of another running nautilus process (1.96 KB, text/plain)
2008-01-26 04:02 EST, Roland Hermans
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 511218 None None None Never

  None (edit)
Description Roland Hermans 2008-01-26 03:57:01 EST
Description of problem:
Since upgrading to Fedora 8 sporadically a nautilus process starts consuming a
lot of CPU time and is continuously writing the line "(USER): debug log dumped
due to signal 11" to the file nautilus-debug-log.txt in the user's home directory.

I'm marking this bug urgent as on our multi-user system a number of these
runaway processes severly impact the system's performance.

Version-Release number of selected component (if applicable):
nautilus-2.20.0-6.fc8
nautilus-cd-burner-2.20.0-1.fc8
nautilus-debuginfo-2.20.0-6.fc8
nautilus-extensions-2.20.0-6.fc8
nautilus-sendto-0.12-5.fc8

How reproducible:
I don't know why the nautilus processes segfault, but when they do they should
not start using all the available CPU time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Nautilus process starts consuming a lot of CPU time and is continuously writing
the line "(USER): debug log dumped due to signal 11" to the file
nautilus-debug-log.txt in the user's home directory.

Expected results:
Write a single line to the file nautilus-debug-log.txt and exit.

Additional info:
- Attached backtrace created with gdb.
- The external bug reference contains a number of references to other bug
reports of the same problem on various distributions. According to
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/153382 just a few days
ago a fix has been released for Hardy.
Comment 1 Roland Hermans 2008-01-26 03:57:01 EST
Created attachment 293043 [details]
gdb backtrace of running nautilus process
Comment 2 Roland Hermans 2008-01-26 04:02:23 EST
Created attachment 293044 [details]
gdb backtrace of another running nautilus process
Comment 4 Fedora Update System 2008-02-21 10:14:00 EST
nautilus-2.20.0-8.fc8 has been submitted as an update for Fedora 8
Comment 5 Roland Hermans 2008-02-21 17:09:03 EST
Thanks for the new nautilus packages. Today I installed them on the system
having showing this problem and for the coming week I'll see what effect it has.
Comment 6 Fedora Update System 2008-02-25 19:25:03 EST
nautilus-2.20.0-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.