Bug 430350 - upgrade from Fedora 6 to Fedora 8 takes too long
upgrade from Fedora 6 to Fedora 8 takes too long
Status: CLOSED DUPLICATE of bug 372011
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 13:29 EST by Michael de Mare
Modified: 2008-01-26 17:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-26 17:44:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael de Mare 2008-01-26 13:29:30 EST
Description of problem:

Algorithm to check dependencies when upgrading Fedora is inefficient.  It 
takes days.

Additional info:

It should be possible to check all dependencies in n log n time.
Comment 1 Jon Stanley 2008-01-26 14:22:27 EST
Some more information is required in order to effectively make any progress on
this.  How many packages were on the FC6 system that was being upgraded to F8? 
Where there any 3rd party repos enabled either during the upgrade or on the FC6
system prior to the upgrade?  What was the installation method?

This is the first time that I have heard of an upgrade taking days.  At what
stage  does it stop and take days?

You mention that this was an upgrade.  I assume that the upgrade was performed
by booting into anaconda and chosing upgrade from there.  Please correct me if I
am mistaken.
Comment 2 Michael de Mare 2008-01-26 16:20:20 EST
It is tied up checking dependencies.  The Fedora Core 6 was a nearly full
install and a number of third party packages and repositories including livna
and freshrpms were added.  I have had similar experiences, however, with
anaconda upgrades without third-party packages that took a day or more.  

I booted the Fedora 8 DVD and instructed it to upgrade the Fedora 6 partition
that it found on the system partition.
Comment 3 Jon Stanley 2008-01-26 17:44:20 EST
This is a known problem - please refer to
http://fedoraproject.org/wiki/Bugs/F8Common#head-7b9bf2dab0e2bdd97d98334c7198cd9cd3eaf9be
for assistance in solving it.

*** This bug has been marked as a duplicate of 372011 ***

*** This bug has been marked as a duplicate of 372011 ***

Note You need to log in before you can comment on or make changes to this bug.