Bug 430357 - gcc reports double-free in testing code using Test::Class
gcc reports double-free in testing code using Test::Class
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl-Test-Class (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 15:31 EST by Colin Kuskie
Modified: 2009-01-09 00:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:51:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (1.62 MB, text/plain)
2008-01-26 15:33 EST, Colin Kuskie
no flags Details

  None (edit)
Description Colin Kuskie 2008-01-26 15:31:13 EST
Description of problem:
I was refactoring tests from using just Test::More to using Test::Class.  Then I
started getting this error:

*** glibc detected *** perl: double free or corruption (fasttop): 0x0a0d2ee8 ***

Now, the same perl code run without Test::Class runs with no problems at all.  I
had a friend checkout my testing code and run it on Mac OSX, and it runs with no
problems at all.



Version-Release number of selected component (if applicable):
I've tried this on FC6, FC7 and FC8, all with the same results with varying
versions of Perl.


How reproducible:
That's the difficult part.  I've tried to winnow this down to a small test case,
and have failed.
Full steps are listed down below.  I'll keep on trying to cut it down, but
it's very resistant to change.

Steps to Reproduce:
1. Create a /data partition
2. cd into /data and checkout a copy of WebGUI
    svn co https://svn.webgui.org/plainblack/branch/colin-experimental
3. Follow the instructions at
http://www.plainblack.com/community-wiki/source-install
   to set up WebGUI.
4. cd into /data/WebGUI/t/
5. env WEBGUI_CONFIG=/data/WebGUI/etc/yourWebGUI.conf perl t/Storage/Image.t
  
Actual results:

All of the tests for the parent class are run, then when it tries to run
the tests for the child it gives this error, and then the process hangs.

*** glibc detected *** perl: double free or corruption (fasttop): 0x0a0d2ee8 ***

Expected results:

All the tests are run.

Additional info:
Comment 1 Colin Kuskie 2008-01-26 15:33:18 EST
Created attachment 293062 [details]
strace output
Comment 2 Marcela Mašláňová 2008-06-12 06:26:18 EDT
It's really long reproducer ;-) 

I suggest upgrade on the latest Test-Class and try again or ask on the cpan, if
they are familiar with those problems.
http://search.cpan.org/~adie/Test-Class-0.30/lib/Test/Class.pm
Comment 3 Steven Pritchard 2008-06-12 10:17:04 EDT
Have you tried this on Fedora 9 (with perl 5.10.0)?

For that matter, Test::Class 0.30 is in rawhide.  It should install on F9 with
no issues, if you wanted to test that too.
Comment 4 Bug Zapper 2008-11-26 04:34:56 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-01-09 00:51:37 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.