Bug 430373 - hdparm says "unknown setting" for Advanced power management level
hdparm says "unknown setting" for Advanced power management level
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hdparm (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 382061
  Show dependency treegraph
 
Reported: 2008-01-26 20:38 EST by Charles R. Anderson
Modified: 2009-06-19 02:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 05:46:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-01-26 20:38:59 EST
Description of problem:
hdparm doesn't report the value of Advanced power management level correctly. 
Instead it says "unknown setting" with a value of (0x8080).  This messes up
retrieving the value to save before suspending and restoring after resuming. 
See Bug #382061.

Version-Release number of selected component (if applicable):
7.7-1.fc8

How reproducible:
always

Steps to Reproduce:
1. hdparm -I /dev/sda

Actual results:

# hdparm -I /dev/sda | grep "Advanced power management level"
	Advanced power management level: unknown setting (0x8080)

Expected results:

The actual power management value, not "unknown setting"

Additional info:

Lenovo ThinkPad T61

# lshal
... 

system.product = '6465CTO ThinkPad T61'  (string)

...

udi = '/org/freedesktop/Hal/devices/storage_serial_SATA_ST9160823AS_5NK0D5J0'
  block.device = '/dev/sda'  (string)
  block.is_volume = false  (bool)
  block.major = 8  (0x8)  (int)
  block.minor = 0  (0x0)  (int)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_serial_SATA_ST9160823AS_5NK0D5J0'  (string)
  info.capabilities = {'storage', 'block'} (string list)
  info.category = 'storage'  (string)
  info.parent =
'/org/freedesktop/Hal/devices/pci_8086_2829_scsi_host_scsi_device_lun0'  (string)
  info.product = 'ST9160823AS'  (string)

Smolt profile:

http://smolts.org/show?UUID=69030fb4-6a8c-4485-94fc-78ec19b2c72b+
Comment 1 Bug Zapper 2008-05-14 00:53:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jan Hutař 2008-10-10 03:19:45 EDT
Hello,
this seems to be fixed in current F10 rawhide (hdparm-8.6-1.fc9.x86_64):


[root@pok etc]# hdparm -B 255 /dev/sda

/dev/sda:
 setting Advanced Power Management level to disabled
[root@pok etc]# hdparm -I /dev/sda | grep "Advanced power management level"
	Advanced power management level: disabled
[root@pok etc]# hdparm -B 128 /dev/sda

/dev/sda:
 setting Advanced Power Management level to 0x80 (128)
[root@pok etc]# hdparm -I /dev/sda | grep "Advanced power management level"
	Advanced power management level: 128
[root@pok etc]# hdparm -B 192 /dev/sda

/dev/sda:
 setting Advanced Power Management level to 0xc0 (192)
[root@pok etc]# hdparm -I /dev/sda | grep "Advanced power management level"
	Advanced power management level: 192


So I think that this can be closed.
Comment 3 Charles R. Anderson 2009-06-19 02:44:04 EDT
As the original reporter, re-confirming fixed in F10, hdparm-8.6-1.fc9.x86_64, Lenovo T61.

Note You need to log in before you can comment on or make changes to this bug.