Bug 430382 - Unhandled exception in banshee, 'remove' from library
Summary: Unhandled exception in banshee, 'remove' from library
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: banshee   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-27 08:06 UTC by Andrew Farris
Modified: 2008-03-08 06:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-08 06:25:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bansheestacktrace.txt (8.23 KB, text/plain)
2008-01-27 08:06 UTC, Andrew Farris
no flags Details
banshee-NDesk.DBus.Bus.txt (7.56 KB, text/plain)
2008-02-29 02:02 UTC, Andrew Farris
no flags Details

Description Andrew Farris 2008-01-27 08:06:08 UTC
Unhandled exception in banshee when 'remove' is selected on item in library. 
The items in the library are not accessible to banshee (location on disk changed).

Nothing is playing or has played, banshee start, then remove item, crash.  

Repeatable.

banshee-0.13.1-1.fc8.i386
gstreamer-0.10.15-1.fc9.i386
mono-winforms-1.2.6-6.1.fc9.i386
mono-core-1.2.6-6.1.fc9.i386
mono-data-sqlite-1.2.6-6.1.fc9.i386
mono-web-1.2.6-6.1.fc9.i386
mono-data-1.2.6-6.1.fc9.i386

glib2-2.15.3-1.fc9.i386
glibc-2.7.90-4.i686

Ambiguous matching in method resolution
System.Reflection.AmbiguousMatchException: Ambiguous matching in method resolution
  at System.Reflection.Binder.FindMostDerivedMatch
(System.Reflection.MethodBase[] match) [0x00000] 
  at System.MonoType.GetMethodImpl (System.String name, BindingFlags
bindingAttr, System.Reflection.Binder binder, CallingConventions callConvention,
System.Type[] types, System.Reflection.ParameterModifier[] modifiers) [0x00000] 
  at System.Type.GetMethod (System.String name, BindingFlags bindingAttr) [0x00000] 
  at Banshee.Base.ReflectionUtil.IsVirtualMethodImplemented (System.Type type,
System.String methodName) [0x00000] 
  at Banshee.Sources.Source.get_CanRemoveTracks () [0x00000] 
  at Banshee.PlayerUI.RemoveSongs (Boolean deleteFromFileSystem) [0x00000] 
  at Banshee.PlayerUI.OnRemoveSongsAction (System.Object o, System.EventArgs
args) [0x00000] 
  at GLib.Signal.voidObjectCallback (IntPtr handle, IntPtr gch) [0x00000] 
  at (wrapper native-to-managed) GLib.Signal:voidObjectCallback (intptr,intptr)
  at (wrapper managed-to-native) Gtk.Application:gtk_main ()
  at Gtk.Application.Run () [0x00000] 
  at Gnome.Program.Run () [0x00000] 
  at Banshee.BansheeEntry.Startup (System.String[] args) [0x00000] 
  at Banshee.Gui.CleanRoomStartup.Startup (Banshee.Gui.StartupInvocationHandler
startup, System.String[] args) [0x00000]

Comment 1 Andrew Farris 2008-01-27 08:06:08 UTC
Created attachment 293069 [details]
bansheestacktrace.txt

Comment 2 Andrew Farris 2008-01-27 08:08:55 UTC
Incidentally, symlinking the prior location of the files (so banshee would have
access to the library location) does not fix it.

Comment 3 Andrew Farris 2008-01-27 08:17:10 UTC
There is a problem going on with selinux and dbus, bug #430381 but this occurs
with setenforce 0, so assuming unrelated on banshee's end.

This still occurs after removing the old db (mv ~/.config/banshee
~/.config/banshee_old; chmod a-rx ~/.config/banshee_old), and then re-importing
at the new file location.

Comment 4 Andrew Farris 2008-02-14 20:21:53 UTC
Ping! Just wanted to note this still occurs without dbus problems and current
rawhide snapshot.

Comment 5 Christopher Aillon 2008-02-23 03:10:45 UTC
There's a new banshee in rawhide.  Please test with that?

Comment 6 Andrew Farris 2008-02-23 09:17:26 UTC
I'll check it soon, I'm out of town at the moment.  I'm glad a rebuild got done
now so hopefully this issue goes away.

Comment 7 Andrew Farris 2008-02-29 02:02:48 UTC
Created attachment 296299 [details]
banshee-NDesk.DBus.Bus.txt

Here is a new problem I get when trying to start banshee-0.13.2-4.fc9.i386.  I
cannot test whether the original problem still occurs since banshee cannot
start at all.  Shortly after running banshee it displays a dialog, part of this
attachment is in terminal, part gets displayed to the dialog.  The last few
lines (assembly version info) is not shown in terminal.

Comment 8 Andrew Farris 2008-02-29 02:04:39 UTC
I'm currently logged into gnome via startx for this testing since GDM login is
not working, so there could be some environment differences I suppose, I notice
some of that error output references path info.

Comment 9 Andrew Farris 2008-03-08 06:25:31 UTC
After mono updates I got today I can start banshee without the previous error. 
I can also import library source from rhythmbox, add, and remove library items,
and play tracks without the original reported unhandled exception occurring.

Closing rawhide (currently working!).


Note You need to log in before you can comment on or make changes to this bug.