Bug 430387 - Build readline, pcsc-lite features
Build readline, pcsc-lite features
Product: Fedora
Classification: Fedora
Component: gnokii (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
: Patch
Depends On:
  Show dependency treegraph
Reported: 2008-01-27 05:54 EST by Ville Skyttä
Modified: 2009-06-18 13:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.6.27-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-18 13:11:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Build libical, pcsc-lite features (983 bytes, patch)
2008-01-27 05:54 EST, Ville Skyttä
no flags Details | Diff
Build with readline and pcsc-lite support (1.33 KB, patch)
2009-06-15 17:12 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2008-01-27 05:54:21 EST
gnokii in Fedora is missing some useful looking functionality due to missing
build dependencies on libical-devel and pcsc-lite-devel.  Patch attached; note
however that pcsc-lite support will (build)require pcsc-lite >= 1.4.2 so it's
applicable to F9 at this time only.
Comment 1 Ville Skyttä 2008-01-27 05:54:21 EST
Created attachment 293070 [details]
Build libical, pcsc-lite features
Comment 2 Bug Zapper 2008-05-14 00:53:58 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 3 Bug Zapper 2009-06-09 19:26:31 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 4 Ville Skyttä 2009-06-15 17:11:26 EDT
libical support seems to be in already, here's an updated patch that adds readline and pcsc-lite (good to have at least for reproducible builds).  Let me know if you'd like me to apply this.
Comment 5 Ville Skyttä 2009-06-15 17:12:12 EDT
Created attachment 348008 [details]
Build with readline and pcsc-lite support
Comment 6 Bastien Nocera 2009-06-15 19:59:16 EDT
Don't see a problem with either of those. Linus?
Comment 7 Linus Walleij 2009-06-18 05:48:58 EDT
Looks good to me, Ville can you build it?
Comment 8 Ville Skyttä 2009-06-18 13:11:59 EDT
Done for Rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=1423171

Note You need to log in before you can comment on or make changes to this bug.