Bug 430391 - Null pointer dereference when bringing up bonding device on kernel-2.6.24-2.fc9.i686
Null pointer dereference when bringing up bonding device on kernel-2.6.24-2.f...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-27 06:30 EST by Benny Amorsen
Modified: 2008-02-06 04:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 17:47:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot log showing the problem (2.03 KB, text/plain)
2008-01-27 06:30 EST, Benny Amorsen
no flags Details

  None (edit)
Description Benny Amorsen 2008-01-27 06:30:57 EST
Description of problem:
Kernel crash when bringing up bonding device.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Make a bonding device, like this:
/etc/sysconfig/networks-scripts/ifcfg-bond0
DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes
TYPE=Bonding

2. Boot kernel-2.6.24-2.fc9.i686
Comment 1 Benny Amorsen 2008-01-27 06:30:57 EST
Created attachment 293073 [details]
boot log showing the problem
Comment 2 Benny Amorsen 2008-01-30 11:24:27 EST
Just a note that the problem persists in 2.6.24-9.fc9
Comment 3 Chuck Ebbert 2008-01-31 17:47:06 EST
Patch taken from netdev#upstream branch put in rawhide.
Comment 4 Benny Amorsen 2008-02-06 04:30:37 EST
The problem is fixed in 2.6.24-17.fc9.

Note You need to log in before you can comment on or make changes to this bug.