Bug 430405 - touchpad horizontal scroll defaults to page forward/back, not scroll horizontally
touchpad horizontal scroll defaults to page forward/back, not scroll horizont...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
2Bupstreamed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-27 12:40 EST by Charles R. Anderson
Modified: 2008-04-03 23:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 23:57:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-01-27 12:40:14 EST
Description of problem:

Scrolling along the bottom of a touchpad causes Firefox to move forward/back in
the history instead of scrolling the current web page horizontally.

Version-Release number of selected component (if applicable):
3.0-0.beta2.12.nightly20080121.fc9

How reproducible:
always

Steps to Reproduce:
1. Make Firefox window small enough so a horizontal scrollbar appears.
2. Slide finger along bottom of synaptics touchpad.

Actual results:

Page back/forward in history.

Expected results:

Scroll horizontally.

Additional info:

This fixes the problem:

Go to: about:config

Search for horiz and set this parameter:

mousewheel.horizscroll.withnokey.action  userset  integer  1

The default value of this parameter should be changed.  Binding this to page
forward/back is just braindead and causes no end to headaches when accidentally
activating the scroll feature of the touchpad.  Scrolling the mouse/touchpad
should cause scrolling, not forward/back.
Comment 1 Charles R. Anderson 2008-04-03 23:57:46 EDT
This seems to be working correctly in FF3 Beta 5.

Note You need to log in before you can comment on or make changes to this bug.