Bug 430413 - yum ignores obsoletes when installing packages
yum ignores obsoletes when installing packages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-27 15:33 EST by Dominik 'Rathann' Mierzejewski
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 12:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root log from mock build (22.73 KB, text/plain)
2008-01-27 15:33 EST, Dominik 'Rathann' Mierzejewski
no flags Details

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2008-01-27 15:33:46 EST
Description of problem:
Yum installs unnecessary package and ignores Obsoletes: in "install" mode.

Version-Release number of selected component (if applicable):
yum-3.2.8-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. ensure faad2\* are not installed
2. yum --enablerepo=livna-testing install faad2-devel
  
Actual results:
$ sudo yum install faad2-devel --enablerepo=livna-testing
Loading "basearchonly" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package faad2-devel.x86_64 0:2.6.1-2.lvn7 set to be updated
--> Processing Dependency: libfaad.so.0()(64bit) for package: faad2-devel
--> Processing Dependency: faad2-libs = 2.6.1-2.lvn7 for package: faad2-devel
--> Running transaction check
---> Package faad2.x86_64 0:2.0-19.20050131.lvn6 set to be updated
---> Package faad2-libs.x86_64 0:2.6.1-2.lvn7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 faad2-devel             x86_64     2.6.1-2.lvn7     livna-testing     8.7 k
Installing for dependencies:
 faad2                   x86_64     2.0-19.20050131.lvn6  livna             202 k
 faad2-libs              x86_64     2.6.1-2.lvn7     livna-testing     165 k

Transaction Summary
=============================================================================
Install      3 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 376 k
Is this ok [y/N]: N
Exiting on user Command
Complete!

Expected results:
$ sudo yum install faad2-devel --enablerepo=livna-testing
Loading "basearchonly" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package faad2-devel.x86_64 0:2.6.1-2.lvn7 set to be updated
---> Package faad2-libs.x86_64 0:2.6.1-2.lvn7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 faad2-devel             x86_64     2.6.1-2.lvn7     livna-testing     8.7 k
Installing for dependencies:
 faad2-libs              x86_64     2.6.1-2.lvn7     livna-testing     165 k

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 173 k
Is this ok [y/N]: N
Exiting on user Command
Complete!
Comment 1 Dominik 'Rathann' Mierzejewski 2008-01-27 15:33:46 EST
Created attachment 293085 [details]
root log from mock build
Comment 2 Dominik 'Rathann' Mierzejewski 2008-01-27 15:35:19 EST
Per http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks ,
faad2-libs-2.6.1-2 has Obsoletes: faad2 < 2.6.1-2.
Comment 3 Seth Vidal 2008-02-21 17:03:49 EST
this patch works for me - running it by other folks to verify the logic:

http://skvidal.fedorapeople.org/patches/yum-rule-out-provides-by-being-obsoletes.patch
Comment 4 Seth Vidal 2008-02-22 12:51:44 EST
okay fix checked in upstream for this bug - modification on a theme of the above
patch.
http://devel.linux.duke.edu/gitweb/?p=yum.git;a=commitdiff;h=fa4f1062a7b31a4b88701b8d9a1af2b28a5022a0

thanks

Note You need to log in before you can comment on or make changes to this bug.