Bug 430457 - ftp shows bitrate in scientific notation
ftp shows bitrate in scientific notation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ftp (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 02:30 EST by JW
Modified: 2008-02-13 00:18 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.17-43.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 00:18:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-01-28 02:30:44 EST
Description of problem:
ftp displays throughput in Kbytes/sec but uses scientific notation.

Version-Release number of selected component (if applicable):
ftp-0.17-42

How reproducible:
Always

Steps to Reproduce:
1.  On link >1Mbps do ftp and see yuk scientific notation bitrate
2.
3.
  
Actual results:
1e+03 KBytes/sec

Expected results:
1000 kBytes/sec or 1MBytes/sec etc

Additional info:
In ftp.c approx line 1555 the %.2g would be better if %.2f and a divisor of 1000
would be more standard than 1024 (because comms rates are normally specified in
iso 1000 multiples).
Comment 1 Marcela Mašláňová 2008-01-28 06:12:47 EST
Thank you for patch. I'll fix it, but if you don't mind, you could switch on
lftp, which is newer and have more features.
Comment 2 Fedora Update System 2008-01-28 06:47:25 EST
ftp-0.17-43.fc8 has been submitted as an update for Fedora 8
Comment 3 JW 2008-01-28 06:53:23 EST
That is hardly the point.  Besides, lftp doesn't need to be 'switched on' - it
isn't a server and neither is ftp. And while lftp may have more features than
there are flies on a kangaroos bum, it doesn't have any extra features that I
need.  Otherwise I would already be using it, wouldn't I?

I do wish that people who are employed to fix bugs would leave their personal
prejudices at home. There is nothing wrong with ftp, but there is plenty wrong
with reinventing the wheel, feature creep, and unsolicited advice.  If I want
your advice about what programs I should be using then I will ask you.
Otherwise, keep it to yourself.

Thanks.
Comment 4 Tomas Mraz 2008-01-28 09:37:11 EST
1. The package maintainer is not native english speaker so you could tolerate
things like using switch on instead of switch to.
2. The package maintainer is employed to maintain the package - as in
integrating into Fedora etc. and not for developing just any feature/idea which
J random user comes with.
Comment 5 JW 2008-01-28 16:45:11 EST
1. Only if one is forewarned that maintainer has no grasp of common language.
2. The fix is for a simple bug which has arisen as data speeds have increased.
There is no new feature/idea.
3. You haven't addressed the issue of unsolicited advice.
Comment 6 Tomas Mraz 2008-01-28 18:13:35 EST
1. I wouldn't say "no grasp".
2. The scientific notation is readable and gives the information. So I'd say
cosmetic flaw.
3. There is no need to address it. I can give even some more to you: Being
polite often helps when you want to achieve something.
4. I would say that you do have "no grasp" on politeness.
Comment 7 Fedora Update System 2008-01-29 00:17:21 EST
ftp-0.17-43.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ftp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1167
Comment 8 Fedora Update System 2008-02-13 00:18:13 EST
ftp-0.17-43.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.