Bug 430458 - execute command "setfacl -- --test" will occur Segmentation Fault
Summary: execute command "setfacl -- --test" will occur Segmentation Fault
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acl   
(Show other bugs)
Version: 5.1
Hardware: i686
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jiri Moskovcak
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-28 08:00 UTC by Peng Haitao
Modified: 2018-10-20 03:40 UTC (History)
7 users (show)

Fixed In Version: 2.2.39-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 08:30:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a patch fixing this bug (440 bytes, patch)
2008-01-28 08:00 UTC, Peng Haitao
no flags Details | Diff
Proposed patch (326 bytes, patch)
2008-01-28 13:18 UTC, Jiri Moskovcak
no flags Details | Diff
Here is a proposed improved fix I'll send "upstream". Thanks. (1.43 KB, patch)
2008-02-25 09:25 UTC, Andreas Gruenbacher
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1652 normal SHIPPED_LIVE acl bug fix update 2009-12-09 08:30:10 UTC

Description Peng Haitao 2008-01-28 08:00:56 UTC
Description of problem:
Using command "setfacl" with option "--" and option "--test", 
Segmentation Fault will occur.

Version-Release number of selected component (if applicable):
acl-2.2.39-2.1.el5

How reproducible:
100%

Steps to Reproduce:
1.setfacl -- --test
  
Actual results:
Segmentation fault

Expected results:
setfacl: --test: No such file or directory

Additional info:

Comment 1 Peng Haitao 2008-01-28 08:00:56 UTC
Created attachment 293136 [details]
This is a patch fixing this bug

Comment 2 Jiri Moskovcak 2008-01-28 13:18:57 UTC
Created attachment 293152 [details]
Proposed patch

Hi, thank you for the patch, but i think it shouldn't print "No such file.." 
because it's wrong usage of the program. So I modified the patch to suit the 
situation better.

Comment 3 Fedora Update System 2008-01-28 15:29:36 UTC
acl-2.2.39-13.fc8 has been submitted as an update for Fedora 8

Comment 4 Fedora Update System 2008-01-28 15:49:16 UTC
acl-2.2.39-7.fc7 has been submitted as an update for Fedora 7

Comment 5 Fedora Update System 2008-01-29 05:13:49 UTC
acl-2.2.39-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2008-01-29 05:16:42 UTC
acl-2.2.39-13.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Andreas Gruenbacher 2008-02-25 09:25:28 UTC
Created attachment 295779 [details]
Here is a proposed improved fix I'll send "upstream". Thanks.

Comment 8 RHEL Product and Program Management 2008-07-21 23:07:11 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 10 RHEL Product and Program Management 2009-03-26 16:50:59 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 16 errata-xmlrpc 2009-12-09 08:30:25 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1652.html


Note You need to log in before you can comment on or make changes to this bug.