Bug 430472 - libpq.so badly built
libpq.so badly built
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 06:18 EST by Bastien Nocera
Modified: 2013-07-02 23:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 13:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-01-28 06:18:20 EST
postgresql-devel-8.2.5-1.fc8

The CVS HEAD version of gnokii doesn't build because libpq.so is built as a
loadable module, and not a shared-library.

*** Warning: Linking the shared library libsmsd_pq.la against the loadable module
*** libpq.so is not portable!
gcc -shared  .libs/pq.o .libs/utils.o  -Wl,--rpath
-Wl,/home/hadess/Projects/Cvs/gnokii/smsd/.libs -Wl,--rpath -Wl,/usr/lib64//smsd
-L/usr/lib64 /home/hadess/Projects/Cvs/gnokii/smsd/.libs/libpq.so  -m64
-mtune=generic -pthread -Wl,-soname -Wl,libsmsd_pq.so -o .libs/libsmsd_pq.so
Comment 1 Tom Lane 2008-01-28 11:53:47 EST
Judging from the given command, gnokii has (mis) built its own copy of libpq.so instead of using the 
system one.  Surely you should be filing this bug against gnokii instead of postgresql?

Another thing that looks pretty bogus there is the rpath that's being embedded into the library ...
Comment 2 Bastien Nocera 2008-01-28 13:08:15 EST
I already corrected this, but the autofools didn't take it into consideration
(as can be seen from the target: libsmsd_pq.la). So already fixed in CVS. Thanks.

Note You need to log in before you can comment on or make changes to this bug.