Bug 430475 - rpm builds fail: redefinition of 'memmove'
rpm builds fail: redefinition of 'memmove'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 07:32 EST by JW
Modified: 2008-04-10 06:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 06:01:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-01-28 07:32:37 EST
Description of problem:
Under certain conditions compilation fails because of conflicting include files.
 This has arisen some time between fc4 and fc8.

Version-Release number of selected component (if applicable):
glibc-2.7-2

How reproducible:
Always

Steps to Reproduce:
1. Compile the following C program:

     =========x.c========
     #include <string.h>
     ====================

   with normal rpm compile flags (/usr/lib/rpm/redhat/macros:%__global_cflags
   which contain (amongst other things) "-O2 -D_FORTIFY_SOURCE=2".
   That is:
        gcc -O2 -D_FORTIFY_SOURCE=2 -c x.c

2.  Now repeat about with the following:
        gcc -O2 -D_FORTIFY_SOURCE=2 -D__USE_STRING_INLINES -c x.c

  
Actual results:
1. Normal compile
2. Error
   In file included from /usr/include/string.h:429,
                 from x.c:3:
   /usr/include/bits/string3.h:58: error: redefinition of 'memmove'


Expected results:
Should compile without conflicting inlined memmove definitions.


Additional info:
Run gcc with -E flag and observe that multiple inlined memmove() definitions are
generated.  One from /usr/include/bits/string.h and the other from
/usr/include/bits/string3.h
Comment 1 Jakub Jelinek 2008-04-10 06:01:30 EDT
Should be fixed in glibc-2.7.90-1 and above in rawhide.

Note You need to log in before you can comment on or make changes to this bug.