Bug 430508 - lynx.cfg: specify TELNET_PATH etc. properly
lynx.cfg: specify TELNET_PATH etc. properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lynx (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 10:28 EST by Dmitry Butskoy
Modified: 2015-02-01 17:47 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.8.6-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-02 04:00:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2008-01-28 10:28:17 EST
For URLs such "telnet://", "rlogin://" etc, Lynx uses TELNET_PATH, RLOGIN_PATH
and so on configuration options.

By default, when such options is not set, Lynx uses compiled-in ones.

In the earlier releases, Lynx caught just the first suitable telnet at the build
machine (usually /usr/kerberos/bin/telnet). Now, when building performs in the
clear "mock" environment, there is no any telnet, hence Lynx knows nothing about
it and friends...

In other words, after upgrading from FC5 to F7, the "telnet://" URLs no more
work under Lynx, because of the reason described above.

To solve this issue, please, add "TELNET_PATH:telnet" (and may be similar for
another protocols) into default /etc/lynx.cfg config file.
Comment 1 Jiri Moskovcak 2008-01-29 04:21:14 EST
Hi,
are you sure you have telnet on your machine? When I try to use URL telnet://.. 
it works even thought I don't have TELNET_PATH set in lynx.cfg.

Jirka
Comment 2 Jiri Moskovcak 2008-01-29 05:00:15 EST
I had modified rpm on my machine installed and as I found out you're right, it 
doesn't work without TELNET_PATH, but I'm not sure if I should modify the cfg 
file that way, I think this should be up to user to set this path ...
Comment 3 Dmitry Butskoy 2008-01-29 08:36:48 EST
> up to user to set this path

Nope.

Actually, Lynx undestands the PATH environment variable. Hence it catch the
first suitable telnet according to the PATH (either /usr/kerberos/bin/telnet, or
/usr/bin/telnet, or even /usr/local/bin/telnet). Thus, for default installation,
we may specify just the short "telnet" without the full path.

The same is true for another similar externals, like "rlogin" etc.

I think all the list (around commented TELNET_PATH in the lynx.cfg) should be
inspected for missing default values, and then lynx.cfg patched to set the
default values for them (where applicable) ...
Comment 4 Fedora Update System 2008-01-30 10:06:55 EST
lynx-2.8.6-10.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-01-30 10:59:30 EST
lynx-2.8.6-5.fc7 has been submitted as an update for Fedora 7
Comment 6 Fedora Update System 2008-02-02 04:00:37 EST
lynx-2.8.6-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-02-02 04:02:48 EST
lynx-2.8.6-10.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.