Bug 430549 - hcid failing to connect to system messagebus
hcid failing to connect to system messagebus
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bluez-utils (Show other bugs)
5.0
All Linux
low Severity low
: rc
: ---
Assigned To: Jiri Moskovcak
desktop-bugs@redhat.com
:
: 222699 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 13:30 EST by Adam Stokes
Modified: 2015-02-01 17:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 13:52:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initscript alteration to address this issue. (2.08 KB, text/x-patch)
2008-01-28 13:30 EST, Adam Stokes
no flags Details
initscript alteration to address this issue. (2.08 KB, patch)
2008-01-28 13:34 EST, Adam Stokes
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-01-28 13:30:47 EST
Description of problem:
It seems hcid (the process for bluetooth) depends on the messagebus service. So,
when messagebus service is not available, hcid daemon outputs the error message
to /var/log/messages.

Version-Release number of selected component (if applicable):
bluez-utils 3.7

How reproducible:
100%

Steps to Reproduce:
1. Attempt to shutdown the box with bluetooth services enabled.
2.
3.
  
Actual results:
hcid loses connection to system messagebus service :
hcid[xxxx]: Can't open system message bus connection: Failed to connect to
socket /var/run/dbus/system_bus_socket: Connection refused

Expected results:
Connection is available to messagebus until not needed.

Additional info:
Comment 1 Adam Stokes 2008-01-28 13:30:47 EST
Created attachment 293177 [details]
initscript alteration to address this issue.
Comment 2 Adam Stokes 2008-01-28 13:34:42 EST
Created attachment 293178 [details]
initscript alteration to address this issue.
Comment 3 RHEL Product and Program Management 2008-01-28 13:35:52 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 RHEL Product and Program Management 2009-03-26 12:50:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 Jarod Wilson 2009-06-11 16:44:24 EDT
*** Bug 222699 has been marked as a duplicate of this bug. ***
Comment 15 RHEL Product and Program Management 2010-08-09 14:25:51 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.