This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 430554 - Traceback in yum during kickstart install
Traceback in yum during kickstart install
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-01-28 14:04 EST by Orion Poplawski
Modified: 2008-02-05 17:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 17:50:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-01-28 14:04:27 EST
Description of problem:

Doing a text mode PXE/http kickstart install.  Kickstart file lists a package
that isn't in the repositories.  Dialog pops up asking to abort or continue. 
Select continue and I get a traceback.  Of course, it might not be related to
that... :-)

Traceback (most recent call first):
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 2215, in remove
  self.logger.critical(_('No Match for argument: %s') % arg)
File "/usr/lib/anaconda/yuminstall.py", line 1558, in deselectPackage
  mbrs = self.ayum.remove(pattern=pkg)
File "/usr/lib/anaconda/kickstart.py", line 1023, in selectPackages
  map(anaconda.backend.deselectPackage, ksdata.packages.excludeList)
File "/usr/lib/anaconda/backend.py", line 214, in doBasePackageSelect
  kickstart.selectPackages(anaconda)
File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
  rc = stepFunc(self.anaconda)
File "/usr/lib/anaconda/dispatch.py", line 132, in gotoNext
  self.gotoNext()
File "/usr/lib/anaconda/text.py", line 588, in run
  (step, instance) = anaconda.dispatch.currentStep()
File "/usr/bin/anaconda", line 1065, in <module>
  anaconda.intf.run(anaconda)
NameError: global name '_' is not defined

Version-Release number of selected component (if applicable):
anaconda-11.4.0.27
Comment 1 Orion Poplawski 2008-01-29 12:12:50 EST
Okay, removed the missing package from the kickstart file but we still get the
traceback, so that's not the cause.  Looks like it's trying to handle the
"-dump" package removal request in the kickstart file.

arg -> 'dump'
Comment 2 James Antill 2008-02-05 17:50:18 EST
from yum.i18n import _

is there in HEAD, so this should go away for 3.2.11.

Note You need to log in before you can comment on or make changes to this bug.