Bug 430558 - PolicyKit prevents pulseaudio from starting
Summary: PolicyKit prevents pulseaudio from starting
Status: CLOSED DUPLICATE of bug 428056
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-28 19:20 UTC by Russell Harrison
Modified: 2008-02-02 19:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-02 19:50:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell Harrison 2008-01-28 19:20:10 UTC
Description of problem:
pulseaudio is no longer able to start because PolicyKit is not granting SUID
privileges.

Version-Release number of selected component (if applicable):
PolicyKit-0.6-1.fc8
pulseaudio-0.9.8-5.fc8

Jan 28 12:53:23 hostname pulseaudio[2840]: polkit.c: Failed to show grant
dialog: Unable to lookup exe for caller
Jan 28 12:53:23 hostname pulseaudio[2840]: polkit.c: PolicyKit responded with
'auth_admin_keep_always'
Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: We are not in group
'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Jan 28 12:53:23 hostname pulseaudio[2840]: pid.c: Daemon already running.
Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: pa_pid_file_create() failed.

Comment 1 David Baron 2008-01-29 05:44:09 UTC
(In reply to comment #0)
> Jan 28 12:53:23 hostname pulseaudio[2840]: polkit.c: Failed to show grant
> dialog: Unable to lookup exe for caller
> Jan 28 12:53:23 hostname pulseaudio[2840]: polkit.c: PolicyKit responded with
> 'auth_admin_keep_always'
> Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: Called SUID root and
> real-time/high-priority scheduling was requested in the configuration. However,
> we lack the necessary priviliges:
> Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: We are not in group
> 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
> Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: For enabling real-time
> scheduling please acquire the appropriate PolicyKit priviliges, or become a
> member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
> for this user.

For what it's worth, pulseaudio starts just fine for me *after* giving these
messages.

> Jan 28 12:53:23 hostname pulseaudio[2840]: pid.c: Daemon already running.
> Jan 28 12:53:23 hostname pulseaudio[2840]: main.c: pa_pid_file_create() failed.

Could the problem be that the daemon is already running or that there's a stale
PID file?

Comment 2 Matthias Clasen 2008-02-02 19:50:41 UTC

*** This bug has been marked as a duplicate of 428056 ***


Note You need to log in before you can comment on or make changes to this bug.