Red Hat Bugzilla – Bug 430559
Requires: libglade-2.0 (in libgnomeui-2.0.pc)
Last modified: 2008-02-01 15:07:46 EST
Description of problem:
$ rpm --requires -q libgnomeui-devel | grep libglade2
libglade2-devel >= 2.0.0
However libgnomeui-2.0.pc does not contain libglade-2.0 in the Requires field.
This forces libgdl to add libglade-2.0 in the Requires field of gdl-1.0.pc to
avoid build failure.
Version-Release number of selected component (if applicable):
(possibly present in F-7 and Rawhide too)
Created attachment 293185 [details]
Patch to fix this bug.
Packages like gnome-build (BuildRequires: libgdl-devel libgnomeui-devel) suffer
build failure due to this.
Sorry for the delayed response.
I don't think this fix is right. libgnomeui-devel requires glade so that it can
add libgnomeui widgets to glade's toolbox. I don't think libgnomeui depends on
Projects that use libglade should explicitly require it in their .pc files.
Ah, alright. I jumped to conclusions seeing libgnomeui-devel require
libglade2-devel and not having it in libgnomeui-2.0.pc.
It turns out that gnome-build's configure.in needed to be patched:
diff -urNp gnome-build-0.2.1.orig/configure.in gnome-build-0.2.1/configure.in
--- gnome-build-0.2.1.orig/configure.in 2008-01-29 01:58:06.000000000 +0530
+++ gnome-build-0.2.1/configure.in 2008-02-02 01:27:00.000000000 +0530
@@ -62,6 +62,7 @@ PKG_CHECK_MODULES(GBF,
gtk+-2.0 >= $GTK_REQUIRED
libgnome-2.0 >= $GNOME_REQUIRED
libgnomeui-2.0 >= $GNOME_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
libbonoboui-2.0 >= $LIBBONOBOUI_REQUIRED
libxml-2.0 >= $XML_REQUIRED
gnome-vfs-2.0 >= $VFS_REQUIRED
Sorry for the noise.