Bug 430559 - Requires: libglade-2.0 (in libgnomeui-2.0.pc)
Requires: libglade-2.0 (in libgnomeui-2.0.pc)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgnomeui (Show other bugs)
8
All Linux
high Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 428566
  Show dependency treegraph
 
Reported: 2008-01-28 14:39 EST by Debarshi Ray
Modified: 2008-02-01 15:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 09:37:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix this bug. (543 bytes, patch)
2008-01-28 14:39 EST, Debarshi Ray
no flags Details | Diff

  None (edit)
Description Debarshi Ray 2008-01-28 14:39:18 EST
Description of problem:

$ rpm --requires -q libgnomeui-devel | grep libglade2
libglade2-devel >= 2.0.0

However libgnomeui-2.0.pc does not contain libglade-2.0 in the Requires field.
This forces libgdl to add libglade-2.0 in the Requires field of gdl-1.0.pc to
avoid build failure.


Version-Release number of selected component (if applicable):

libgnomeui-devel-2.20.1.1-1.fc8
(possibly present in F-7 and Rawhide too)
Comment 1 Debarshi Ray 2008-01-28 14:39:18 EST
Created attachment 293185 [details]
Patch to fix this bug.
Comment 2 Debarshi Ray 2008-01-28 15:11:13 EST
Packages like gnome-build (BuildRequires: libgdl-devel libgnomeui-devel) suffer
build failure due to this.
Comment 3 Ray Strode [halfline] 2008-02-01 09:37:09 EST
Hi rishi,

Sorry for the delayed response.

I don't think this fix is right.  libgnomeui-devel requires glade so that it can
add libgnomeui widgets to glade's toolbox.  I don't think libgnomeui depends on
libglade.

Projects that use libglade should explicitly require it in their .pc files.
Comment 4 Debarshi Ray 2008-02-01 15:07:46 EST
Ah, alright. I jumped to conclusions seeing libgnomeui-devel require
libglade2-devel and not having it in libgnomeui-2.0.pc.

It turns out that gnome-build's configure.in needed to be patched:

diff -urNp gnome-build-0.2.1.orig/configure.in gnome-build-0.2.1/configure.in
--- gnome-build-0.2.1.orig/configure.in 2008-01-29 01:58:06.000000000 +0530
+++ gnome-build-0.2.1/configure.in      2008-02-02 01:27:00.000000000 +0530
@@ -62,6 +62,7 @@ PKG_CHECK_MODULES(GBF,
        gtk+-2.0 >= $GTK_REQUIRED 
        libgnome-2.0 >= $GNOME_REQUIRED
        libgnomeui-2.0 >= $GNOME_REQUIRED
+       libglade-2.0 >= $LIBGLADE_REQUIRED
        libbonoboui-2.0 >= $LIBBONOBOUI_REQUIRED
        libxml-2.0 >= $XML_REQUIRED
        gnome-vfs-2.0 >= $VFS_REQUIRED

Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.