Bug 430602 - ksh segfaults
ksh segfaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ksh (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 18:16 EST by ritz
Modified: 2008-02-18 05:17 EST (History)
0 users

See Also:
Fixed In Version: 20080202-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 05:17:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2008-01-28 18:16:42 EST
Description of problem:
ksh segfaults

How reproducible:
always

Steps to Reproduce:
$ uname -i
x86_64 

$ cat o
unset VAR
echo ${VAR}

$ ksh o

Actual results:
ksh segfaults

Expected results:
ksh should not segafult
Comment 1 Tomas Smetana 2008-01-29 01:53:59 EST
I failed to reproduce the bug with ksh-20071105-2.fc8.
Comment 3 Tomas Smetana 2008-01-29 04:24:23 EST
I can reproduce this bug only with OPTIND variable.
Comment 4 ritz 2008-01-29 04:35:34 EST
noticed this now. And for this is applicable for i386 also.
Comment 5 ritz 2008-01-29 04:37:03 EST
OPTIND seems to be a reserved variable within ksh.
Comment 6 Tomas Smetana 2008-01-29 09:09:54 EST
OK.  I think I have a fix.  I've sent it upstream for a review to verify it's
correct.
Comment 7 Fedora Update System 2008-01-30 03:16:42 EST
ksh-20071105-3.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-02-01 20:18:21 EST
ksh-20071105-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ksh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1202
Comment 9 Tomas Smetana 2008-02-18 05:17:04 EST
ksh-20071105-3.fc8 has been obsoleted by ksh-20080202-1.fc8 that was pushed to
stable repository.  Closing.

Note You need to log in before you can comment on or make changes to this bug.