Bug 430611 - Open Office Writer can't print on Fedora 8
Open Office Writer can't print on Fedora 8
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2008-01-28 19:41 EST by David
Modified: 2008-03-10 07:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-10 07:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Here is the .odt (191.98 KB, application/octet-stream)
2008-01-30 17:44 EST, David
no flags Details
postscript from "print to file" (200.45 KB, application/postscript)
2008-01-31 03:35 EST, Caolan McNamara
no flags Details
This is output from office (284.14 KB, application/postscript)
2008-03-05 06:20 EST, David
no flags Details
Changed the banner anchor 'to character' (284.15 KB, application/postscript)
2008-03-05 07:05 EST, David
no flags Details
error log as per proceedure requested (36.31 KB, application/octet-stream)
2008-03-07 23:38 EST, David
no flags Details

  None (edit)
Description David 2008-01-28 19:41:53 EST
Description of problem:
Try to print any open office writer document, it sends to cups but disappears
from cups.  Cups says its been printed.  Only writer has the bug, spreadsheet
prints fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Caolan McNamara 2008-01-29 02:54:18 EST
I simply cannot imagine a generic printing scenario that would affect writer but
not calc. 

Give the background story, does it happen with just one particular document, did
it *always* happen as far as you know with all documents, did it just start
happening, if you e.g. "print to file", and open that file in evince does it
display, and if you print then from evince that postscript does it work ?
Comment 2 David 2008-01-29 04:16:53 EST
I found all my company documents won't print.  If I do a clean document it will
print.  It turns out to be the corporate image at the top if I click it it says
some error about the OLE link.

However I have used openoffice since Fedora 6 and I have never had this issue. 
It must be something in the latest openoffice update.

Do you want me to attach a document for testing?

I even tried cutting and pasting the OLE image into a clean document, as soon as
the OLE is pasted in the print goes to cups and the print icon goes dark then to
ghosted way too fast (it normally takes time for it to spool and then print, and
then it ghosts).

So something is amiss as why its rejecting documents that works in previous
openoffice.  I have tried docs saved as .doc to be word compatiable, but even
old ones back as far as fedora 6, so its simply not a recent document thing.

Maybe OLE is broken completely?

Comment 3 Caolan McNamara 2008-01-29 04:25:24 EST
Please attach a known reproducer if you can. I cannot see any reason whatsoever
for there to be a change in behaviour due to a openoffice.org update, the last
one was merely to change serbian translations. That the element is an ole2
object might be a red-herring and the problem might simply be that of the image
itself. It may even lie elsewhere outside of OOo.

rpm -q openoffice.org-core
rpm -q cups

I wonder if there is any output in /var/log/cups/error_log when you print, i.e.
trying to figure out if OOo is not producing any output to the printing system
at all, of it is producing output which is causing a problem.
Comment 4 David 2008-01-29 16:19:09 EST
Thanks for the reply, here is the information and extract of a few print jobs I
tried yesterday when I noticed the problem.

[root@three ~]# rpm -q openoffice.org-core
[root@three ~]# rpm -q cups

Extract from /var/log/cups/error_log

I [29/Jan/2008:11:31:04 +1100] [Job 73] Adding end banner page "none".
I [29/Jan/2008:11:31:04 +1100] [Job 73] Queued on "HP_Color_LaserJet_2600n" by
I [29/Jan/2008:11:31:04 +1100] [Job 73] Started filter
/usr/lib/cups/filter/pstops (PID 3313)
I [29/Jan/2008:11:31:04 +1100] [Job 73] Started filter
/usr/lib/cups/filter/foomatic-rip (PID 3314)
I [29/Jan/2008:11:31:04 +1100] [Job 73] Started backend
/usr/lib/cups/backend/usb (PID 3315)
I [29/Jan/2008:11:31:05 +1100] [Job 73] Completed successfully.
I [29/Jan/2008:11:32:30 +1100] [Job 74] Adding start banner page "none".
I [29/Jan/2008:11:32:30 +1100] [Job 74] Adding job file of type
I [29/Jan/2008:11:32:30 +1100] [Job 74] Adding end banner page "none".
I [29/Jan/2008:11:32:30 +1100] [Job 74] Queued on "HP_Color_LaserJet_2600n" by
I [29/Jan/2008:11:32:30 +1100] [Job 74] Started filter
/usr/lib/cups/filter/pstops (PID 3376)
I [29/Jan/2008:11:32:30 +1100] [Job 74] Started filter
/usr/lib/cups/filter/foomatic-rip (PID 3377)
I [29/Jan/2008:11:32:30 +1100] [Job 74] Started backend
/usr/lib/cups/backend/usb (PID 3378)
I [29/Jan/2008:11:32:31 +1100] [Job 74] Completed successfully.
I [29/Jan/2008:11:34:01 +1100] [Job 75] Adding start banner page "none".
I [29/Jan/2008:11:34:01 +1100] [Job 75] Adding job file of type
I [29/Jan/2008:11:34:01 +1100] [Job 75] Adding end banner page "none".
I [29/Jan/2008:11:34:01 +1100] [Job 75] Queued on "HP_Color_LaserJet_2600n" by
I [29/Jan/2008:11:34:01 +1100] [Job 75] Started filter
/usr/lib/cups/filter/pstops (PID 3416)
I [29/Jan/2008:11:34:01 +1100] [Job 75] Started filter
/usr/lib/cups/filter/foomatic-rip (PID 3417)
I [29/Jan/2008:11:34:01 +1100] [Job 75] Started backend
/usr/lib/cups/backend/usb (PID 3418)
I [29/Jan/2008:11:34:02 +1100] [Job 75] Completed successfully.
I [29/Jan/2008:11:34:14 +1100] [Job 76] Adding start banner page "none".
I [29/Jan/2008:11:34:14 +1100] [Job 76] Adding job file of type
I [29/Jan/2008:11:34:14 +1100] [Job 76] Adding end banner page "none".
I [29/Jan/2008:11:34:14 +1100] [Job 76] Queued on "HP_Color_LaserJet_2600n" by
I [29/Jan/2008:11:34:14 +1100] [Job 76] Started filter
/usr/lib/cups/filter/pstops (PID 3450)
I [29/Jan/2008:11:34:14 +1100] [Job 76] Started filter
/usr/lib/cups/filter/foomatic-rip (PID 3451)
I [29/Jan/2008:11:34:14 +1100] [Job 76] Started backend
/usr/lib/cups/backend/usb (PID 3452)
I [29/Jan/2008:11:34:14 +1100] [Job 76] Completed successfully.
Comment 5 Caolan McNamara 2008-01-30 02:52:21 EST
Aother thing to try and isolate now is to use print to file (as postscript) of a
known not-working document, i.e. one with the header. 

Open that .ps with evince and see if it renders fine there, if it does, print to
printer of it from evince and see if that works. If it fails on either step then
attach that ps and the original .odt here.
Comment 6 David 2008-01-30 17:44:52 EST
Created attachment 293507 [details]
Here is the .odt

If you delete the graphic it prints.  For some reason it now does not like the
Comment 7 Caolan McNamara 2008-01-31 03:35:12 EST
Created attachment 293557 [details]
postscript from "print to file"

Unfortunately (for you) that .odt printed fine on my simple little printer, So
attached here is my output from "print to file" as postscript.

Can you download and open this attachment in evince and try and use print from
evince and see if *that* works, i.e. if we can reproduce the problem using just
the postscript output.
Comment 8 David 2008-02-02 03:18:30 EST
Well I still have problems printing it :(

I found in doc writer if I right click the image, select object, and change the
anchor from the bottom
As character
To character it prints fine

So something is different. 
Comment 9 Caolan McNamara 2008-02-04 03:21:08 EST
The important question for me is if you mean by "it" that trying to print the
.ps from comment #7 from e.g. evince fails ? i.e. that we can confirm that the
problem is reproducible with that standalone example on your setup ?
Comment 10 David 2008-02-05 16:56:03 EST
It was not only the attached document (mine), but any of my own saved documents,
even in .doc format.  I don't have evince installed as I use thunderbird and its
been removed.

However if I download your document, it opens up in document viewer and this
prints ok.

Also as I mentioned in my last reply, if I change the anchor from 'As character'
to 'To character' in open office writer it does print fine.

It makes no sense why these documents need the anchor changed.  My printer and
hardware is identical.  It seems to be how open office handles the banner,
certainly to my HP Color LaserJet 2600n

I never had any issues on Fedora 6 and 7 and I have been running 8 since a week
after it was launched.
Comment 11 Caolan McNamara 2008-02-06 12:57:21 EST
yeah, "document viewer" is evince, (evolution is the email client that
thunderbird can replace). So if the .ps targeted for the "generic printer" works
then lets try to capture the .ps targeted to the "real printer".

This should work to do that...

a) tools->options->openoffice.org->general->use openoffice.org dialogs
b) file->print->select the troublesome printer and toggle "print to file" on
and save that .ps someplace

I then suggest repeating the above, except this time selecting the "Generic
Printer" and saving that .ps to another location.

Now try and open those two .ps files in evince/Document Viewer and print each of
them from there and see if they both succeed or if one of them fails. If one
fails, then attach both .ps files here and our problem will be in there somewhere.

If they both succeed then I'm a little baffled and it might be some
printer-specific setting passed down to the printer outside of the .ps itself
that's causing the problem.
Comment 12 David 2008-02-08 18:12:33 EST
It see,s to be something to do with the printer.  It refuses to print anything
(if a saved .ps or direct print) if I have the anchor set to 'As character'. 
However as soon as the anchor is set to 'To character' if prints directly, or
the saved .ps prints

At least I can print by modifying the anchor on the document.

Maybe its some limitation?  Certainly one thing I notice, is to me it looks like
its not even trying to print.  I see the printer icon appear on the system tray
so short and briefly I haddly have time to click it to launch the printer status.

However once the anchor is toggled the system tray printer appears for the
normal 20 odd or so seconds.
Comment 13 Caolan McNamara 2008-02-13 05:35:38 EST
Can you please attach the saved .ps which reproduces this problem for you when
printed from e.g. evince.
Comment 14 David 2008-02-21 22:07:35 EST
Okay seems the issue is there is a graphic as well as my signature in the page

If I change the top graphic from Anchor 'as character' to 'to character' and
leave the signature as 'as character' it prints happily.

If I change the signature it will still not print, the banner has to be changed.

Evince is the same, if I print to a .ps it wont print if both the banner and
signature are 'as character', but change the banner to 'to character' as anchor
and they print.
Comment 15 Caolan McNamara 2008-02-22 03:23:30 EST
See comment #11, and comment #13, can you please attach the saved .ps which
reproduces this problem for you when printed from e.g. evince.

That's the only thing I want to get my hands on, a ps file known not to work for
you. The other details are not helping at this stage.
Comment 16 David 2008-03-04 18:37:41 EST
Sorry I have been away I will attach the files tonight.
Comment 17 David 2008-03-05 06:20:52 EST
Created attachment 296871 [details]
This is output from office

This is the output.ps
It wont print (the actual doc) out of writer.  I printed it as output.ps
If I load into evince, it displays but again I print and nothing.
Comment 18 Caolan McNamara 2008-03-05 06:41:06 EST
So the attachment #17 [details] contains an output.ps which when printed will fail to work
? Excellent.

I see that the paper size of the document/postscript is A4 and that the printer
is a "HP Color LaserJet 2600n" ? So could you paste in text of the make and
model found under system->administration->printing for this printer. 

I wonder if this is related to bug #434803 which is also a hp postscript
printer, though a different model. Is it A4 paper in the printer ?
Comment 19 Tim Waugh 2008-03-05 07:04:14 EST
That output.ps file prints fine as PostScript (on an HP LaserJet 6MP) or through
hpijs (on an HP DeskJet 990C), so the problem is most likely with the PPD file
or  the underlying driver.  Definitely need to see the 'make and model' text
from System->Administration->Printing (as in comment #18) to know more about the
Comment 20 David 2008-03-05 07:05:15 EST
Created attachment 296874 [details]
Changed the banner anchor 'to character'

HP Color LaserJet 2600n Foomatic/foo2hp (recommended)

Yes its definitely A4 paper, as well as the printer is set in
system->administration->printing to A4

But what is weird, if I change the banner (the logo at the top) in writer the
anchor 'as character' then 'to character' it prints perfectly... 

I have attached it for you (and yes it prints directly out of writer and
Comment 21 Tim Waugh 2008-03-05 07:53:48 EST
David, please follow these instructions so that we can see some debugging
output.  Run the commands as root.

1. Enable debugging:

/sbin/cupsctl --debug-logging

2. Stop CUPS:

/sbin/service cups stop

3. Clear out the error_log file:


4. Start CUPS:

/sbin/service cups start

5. Now print your job with the banner set to anchor as character, so that the
print job fails.  It is important to make sure the print job fails so that we
can see the debugging output from the failure.

6. Now go to http://localhost:631/admin/log/error_log and select File->Save Page
As.. and save it as 'error_log'

7. Add error_log to this bug reporrt as an attachment.

Comment 22 David 2008-03-07 23:38:06 EST
Created attachment 297267 [details]
error log as per proceedure requested
Comment 23 Tim Waugh 2008-03-10 07:00:08 EDT
Seems like a problem with the (3rd party) foo2hp driver: it only writes 72 bytes
for that PostScript, whereas other drivers print fine.

Changing to CANTFIX, as this is not part of Fedora.

Note You need to log in before you can comment on or make changes to this bug.