Bug 430623 - pdf callout link display bug
pdf callout link display bug
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Michael Hideo
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 00:36 EST by Christopher Curran
Modified: 2010-11-23 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 19:13:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a picture of the error (16.12 KB, application/octet-stream)
2008-01-29 00:36 EST, Christopher Curran
no flags Details

  None (edit)
Description Christopher Curran 2008-01-29 00:36:41 EST
Description of problem:
The bug in pdf displaying headings. From the file
https://engineering.redhat.com/docbot/en-US/Red_Hat_Enterprise_Linux/0.0.0/pdf/Oracle_Tuning_Guide/Oracle_Tuning_Guide.pdf
Links don't compress properly in callout boxes.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The link doesn't wrap in pdf

Expected results:
the link wraps in pdf

Additional info:
See the picture provided
Comment 1 Christopher Curran 2008-01-29 00:36:41 EST
Created attachment 293237 [details]
a picture of the error
Comment 2 Jeff Fearn 2008-01-29 01:56:42 EST
This is probably due to the same bug if FOP that prevents it from wrapping urls
in footnotes and screens.

I suggest we remove the extra link since almost all PDF viewers have a "copy
url" option on the right mouse button menu; so there is really no need to have
the url in plain text.

This would require setting ulink.show to zero in main-pdf.xsl

Alternately you could force the text URL to be generated in a footnote instead
of in the table by setting ulink.footnotes to 1 in main-pdf.xsl

Alternately we could try restructuring the fo output to find a structure FOP is
happy with. This would take a fair while to get around to.
Comment 3 Jeff Fearn 2008-02-17 19:13:33 EST
I forced the urls to be in foot notes, this not only fixes this issue, it makes
the text more readable.

Note You need to log in before you can comment on or make changes to this bug.