Bug 430641 - (CVE-2006-4980) CVE-2006-4980 python repr unicode buffer overflow
CVE-2006-4980 python repr unicode buffer overflow
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
http://nvd.nist.gov/nvd.cfm?cvename=C...
impact=important,source=vendorsec,rep...
: Security
Depends On: 208162 430872 436512 440511 449461
Blocks: 444136
  Show dependency treegraph
 
Reported: 2008-01-29 04:46 EST by Mark J. Cox (Product Security)
Modified: 2015-08-24 12:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 12:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark J. Cox (Product Security) 2008-01-29 04:46:51 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2006-4980 to the following vulnerability:

Buffer overflow in the repr function in Python 2.3 through 2.6 before 20060822 allows context-dependent attackers to cause a denial of service and possibly execute arbitrary code via crafted wide character UTF-32/UCS-4 strings to certain scripts.

References:

http://www.securityfocus.com/archive/1/archive/1/448244/100/100/threaded
http://www.securityfocus.com/archive/1/archive/1/456546/100/200/threaded
http://sourceforge.net/tracker/index.php?func=detail&aid=1541585&group_id=5470&atid=305470
http://zoehep.xent.com/~bsittler/python2.4-2.4.3_unicodeobject.c.diff
https://launchpad.net/distros/ubuntu/+source/python2.4/+bug/56633
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=208162
https://issues.rpath.com/browse/RPL-702
http://support.avaya.com/elmodocs2/security/ASA-2006-229.htm
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=391589
http://www.vmware.com/support/vi3/doc/esx-3069097-patch.html
http://www.vmware.com/support/vi3/doc/esx-9986131-patch.html
http://kb.vmware.com/KanisaPlatform/Publishing/882/5120103_f.SAL_Public.html
http://www.debian.org/security/2006/dsa-1197
http://www.debian.org/security/2006/dsa-1198
http://security.gentoo.org/glsa/glsa-200610-07.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2006:181
http://www.redhat.com/support/errata/RHSA-2006-0713.html
ftp://patches.sgi.com/support/free/security/advisories/20061001-01-P.asc
http://www.novell.com/linux/security/advisories/2006_25_sr.html
http://www.ubuntu.com/usn/usn-359-1
http://www.securityfocus.com/bid/20376
http://www.frsirt.com/english/advisories/2006/3940
http://www.frsirt.com/english/advisories/2006/5131
http://securitytracker.com/id?1017019
http://secunia.com/advisories/22276
http://secunia.com/advisories/22303
http://secunia.com/advisories/22357
http://secunia.com/advisories/22297
http://secunia.com/advisories/22358
http://secunia.com/advisories/22379
http://secunia.com/advisories/22448
http://secunia.com/advisories/22512
http://secunia.com/advisories/22531
http://secunia.com/advisories/22639
http://secunia.com/advisories/22487
http://secunia.com/advisories/23680
http://xforce.iss.net/xforce/xfdb/29408
Comment 1 Mark J. Cox (Product Security) 2008-01-29 04:47:39 EST
for patch and more details see
https://bugzilla.redhat.com/show_bug.cgi?id=208162
Comment 3 Vincent Danen 2010-12-22 12:21:08 EST
This was addressed via:

Red Hat Enterprise Linux version 3 (RHSA-2006:0713)
Red Hat Enterprise Linux version 4 (RHSA-2006:0713)
Red Hat Network Satellite Server 5.0 (RHEL v.4 AS) (RHSA-2008:0264)
Red Hat Network Satellite Server v 4.2 (RHEL v.3 AS) (RHSA-2008:0525)
Red Hat Network Satellite Server v 4.2 (RHEL v.4 AS) (RHSA-2008:0525)
Red Hat Network Satellite Server 5.1 (RHEL v.4 AS) (RHSA-2008:0629)

Note You need to log in before you can comment on or make changes to this bug.