Bug 430656 - k3b verify fail
k3b verify fail
Status: CLOSED DUPLICATE of bug 440343
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 05:22 EST by cornel panceac
Modified: 2008-04-06 11:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 08:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2008-01-29 05:22:41 EST
Description of problem:

k3b fails to verify that the burned cd from iso is ok, although it is.


Version-Release number of selected component (if applicable):
k3b-1.0.4-5.fc8

How reproducible:
most of the times. (three out of four)


Steps to Reproduce:
1.open with k3b an cd iso
2.check the "verify" box
3.wait for the verify to finish
  
Actual results:
verify failed

Expected results:
veriy ok

Additional info:

the isos where latest freedos 1.0 full cd, and reactos 0.3.4 install.
tried also the older kernel but didn't help.
then i've used nautius to copy the "broken" cd's to image file, compared the
md5sum and were identical.
Comment 1 Sebastian Vahl 2008-03-26 10:20:26 EDT
Same here. Verification fails for every burned image I've tried (CD and DVD). 
But the burned image itself is fine (compared to the matching SHA1SUMs of ISO 
and /dev/sr1).

k3b-1.0.4-5.fc8.x86_64
Comment 2 Rex Dieter 2008-03-26 10:30:01 EDT
I wonder what method k3b is using to "verify".  Hmm... regardless, this sounds
like a good candidate to bounce upstream to bugs.kde.org.
Comment 3 Rex Dieter 2008-04-03 07:59:44 EDT
Naw, looks like an issue with recent kernels, see bug #440343
Comment 4 Rex Dieter 2008-04-03 08:00:02 EDT

*** This bug has been marked as a duplicate of 440343 ***
Comment 5 Michael Schwendt 2008-04-05 05:36:57 EDT
Are you sure this is a duplicate? It was filed 2008-01-29 when
kernel 2.6.24 was not current.
Comment 6 Rex Dieter 2008-04-05 10:13:49 EDT
Excellent question.  cornel and svahl, can you confirm which kernel's you're
using the exhibit this behavior?
Comment 7 cornel panceac 2008-04-05 10:42:08 EDT
i don't remember wich kernel but, the story is like this: first it worked. then
(after some kernel/k3b/wodim updates) it doesn't. then i get the k3b from
updates-testing and, without changing the kernel (just a guess, not 100% sure,
but close) it worked again. then after i_don't_know_wich_updates it started
again to show the bug. the behaviour is the same so i suppose it's the same bug:
dvd verify ok, cd's not ok.
Comment 8 Sebastian Vahl 2008-04-06 11:17:01 EDT
(In reply to comment #6)
> Excellent question.  cornel and svahl, can you confirm which kernel's you're
> using the exhibit this behavior?

(I accidentaly posted my reply to the wrong bug, so doing c&p here):

I was only able to do a short test, because I've had problems to install a
2.6.23 on my normal machine. And I only had access to this test machine this sunday.

Test was done with k3b-1.0.4-5.fc8 on i386. Media was Fedora-8-i386-rescuecd.iso
and a CD-RW.

Kernel: 2.6.24.3-34.fc8
k3b: verify failed
SHA1SUM: ok

2.6.24.4-64.fc8
k3b: verify failed
SHA1SUM: ok

Kernel: 2.6.23.15-137.fc8
k3b: verify succeeded
SHA1SUM: ok
Comment 9 Michael Schwendt 2008-04-06 11:35:56 EDT
Perhaps around 2008-01-29 a 2.6.24* test kernel was made available
already. Also note that one k3b update had been published with bad
tray reloading code and broke DVD/CD verification in a different way.

svahl only added himself end of march, so he sees bug 440343

Note You need to log in before you can comment on or make changes to this bug.