Bug 430672 - Update portaudio to build against the new libjack in rawhide
Update portaudio to build against the new libjack in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: portaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 08:07 EST by Francois Aucamp
Modified: 2008-02-03 06:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 06:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Francois Aucamp 2008-01-29 08:07:03 EST
The espeak package (which links to libportaudio) fails to build in rawhide, due
to binary incompatibility in the new JACK in rawhide. It fails due to the
following missing symbols:

libportaudio.so: undefined reference to `jack_port_lock'
libportaudio.so: undefined reference to `jack_port_unlock'

...which are not present in the latest rawhide version of JACK.

This was also discussed here:

https://www.redhat.com/archives/fedora-devel-list/2008-January/msg02962.html


Please update portaudio to build against the new libjack (libjack.so.0.0.28 at
the time of writing).
Comment 1 Matthias Saou 2008-02-03 06:07:31 EST
Thanks for the report! I've updated portaudio to the latest v19 (which provides
the same soname, so shouldn't break anything), which will have linked against
the new jack.

Note You need to log in before you can comment on or make changes to this bug.