Bug 430724 - uninstall fails
uninstall fails
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: freeipa10 429034
  Show dependency treegraph
 
Reported: 2008-01-29 11:30 EST by Suzanne Hillman
Modified: 2012-03-27 03:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 03:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use correct variable when restoring a file (890 bytes, patch)
2008-01-31 10:28 EST, Rob Crittenden
no flags Details | Diff

  None (edit)
Description Suzanne Hillman 2008-01-29 11:30:55 EST
Unsure if this is important, since I believe that this came from an external source.

Description of problem:
[root@ipaqa02 yum.repos.d]# ipa-server-install --uninstall
Unexpected error - see ipaserver-install.log for details:
 unsupported operand type(s) for +: 'NoneType' and 'str'

In the log:
2008-01-29 08:17:18,451 DEBUG unsupported operand type(s) for +: 'NoneType' and
'str'
  File "/usr/sbin/ipa-server-install", line 500, in <module>
    main()

  File "/usr/sbin/ipa-server-install", line 301, in main
    return uninstall()

  File "/usr/sbin/ipa-server-install", line 276, in uninstall
    ipaserver.bindinstance.BindInstance().uninstall()

  File
"/var/tmp/ipa-server-0.6.0-4-root-root/usr/lib/python2.5/site-packages/ipaserver/bindinstance.py",
line 120, in uninstall

Version-Release number of selected component (if applicable):
i386 2008-01-29_03_01-build

How reproducible:
Always, after an install (behavior changes if you run it a second time without
an install between).

Steps to Reproduce:
1. Do a server install.
2. Do an uninstall
  
Actual results:
The error above.

Expected results:
No error.

Additional info:
Comment 3 Rob Crittenden 2008-01-31 10:28:35 EST
Created attachment 293589 [details]
use correct variable when restoring a file

Patch provided by Mark McLoughlin.

Committed in changeset 612.
Comment 5 Suzanne Hillman 2008-03-13 16:54:40 EDT
Ok, this time it just worked cleanly first try. This is therefore verified with
the  0.99-18.715.20080312.el5ipa ipa-server rpm.

Note You need to log in before you can comment on or make changes to this bug.