Bug 430756 - Provide libsoup-2.2 compat library
Provide libsoup-2.2 compat library
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libsoup (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On: 430978
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 12:59 EST by Dmitry Butskoy
Modified: 2008-03-06 07:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 07:02:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2008-01-29 12:59:45 EST
Please, provide libsoup-2.2 compat library (as a separate package).

The newest libsoup-2.3.0 has new API, incompatible with the 2.2.x series, and
even introduces some design changes. This prevents the easy adoption of rawhide
applications, who depends on libsoup.

F.e., in a case of "libtranslate" it requries a deep upstream work, because
"libtranslate" uses "soup filters", which no more supported since the 2.3.x branch.
Comment 1 Matthew Barnes 2008-01-29 15:13:35 EST
New Package CVS Request
=======================
Package Name: libsoup-compat
Short Description: provide libsoup-2.2 API in F9 for backward compatibility
Owners: mbarnes
Branches: (none)
InitialCC:
Cvsextras Commits: yes

Basically I just want to provide the latest "libsoup" package from Fedora 8 as
"libsoup-compat" in Fedora 9.
Comment 2 Matthew Barnes 2008-01-29 15:17:36 EST
Meanwhile, Dmitry, you might want to enlist Dan Winship's help in porting
libtranslate to the new API.
Comment 3 Matthew Barnes 2008-01-29 15:19:29 EST
Oops, wrong flag...
Comment 4 Dmitry Butskoy 2008-01-30 07:24:03 EST
I would prefer the name of "libsoup22" (and "libsoup22-devel" for devel).

The name of "compat-libsoup" does not specify that it is *exactly" the version
of 2.2, and this package will never have another != 2.2 version...
Comment 5 Kevin Fenzi 2008-01-30 12:23:22 EST
All new packages (even compat) must go through review. Matthew is going to
submit this for review soon... clearing cvs flag. 
Comment 6 Dan Winship 2008-01-30 14:38:08 EST
I've already given Dmitry a patch for libtranslate, and I'm working on some
other packages. But drivel in particular is going to take a while.

BTW, the gentoo maintainer pointed out to me that libsoup 2.2 and 2.4 conflict
in /usr/share/gtk-doc/html/libsoup, so you'll have to fix that one way or the other.
Comment 7 Matthew Barnes 2008-01-30 14:51:38 EST
Easiest solution would be to just disable API documentation on the compat
package and point people to http://library.gnome.org/devel/libsoup/2.2/.
Comment 8 Matthew Barnes 2008-01-30 16:45:37 EST
Bug #430978 is the package review request (libsoup22).

This is exactly what we ship in Fedora 8, minus the API documentation.

Note You need to log in before you can comment on or make changes to this bug.