Bug 430772 - Anaconda fails to show traceback window or generate anacdump.txt
Summary: Anaconda fails to show traceback window or generate anacdump.txt
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2008-01-29 18:24 UTC by Will Woods
Modified: 2008-01-29 19:16 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 19:16:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Will Woods 2008-01-29 18:24:17 UTC
I caused a traceback in anaconda-11.4.0.27 (see bug 428891), but rather than
popping up the traceback window and generating anacdump, anaconda simply hung.

It turns out there was a traceback in sys.excepthook, which follows:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1062, in <lambda>
  File "/usr/lib/anaconda/exception.py", line 407, in handleException
  File "/usr/lib/anaconda/gui.py", line 1101, in mainExceptionWindow
  File "/usr/lib/anaconda/gui.py", line 983, in __init__
  File "/usr/lib/anaconda/gui.py", line 907, in __init__
  File "/usr/lib/anaconda/gui.py", line 413, in findGladeFile
RuntimeError: Unable to find glade file detailed-dialog.glade

/mnt/runtime/usr/share/anaconda/ui/detailed-dialog.glade does exist and is readable.

Comment 1 Chris Lumens 2008-01-29 19:16:15 UTC
We can't display a useful exception message here, but we can at least log an
error and not traceback.  I hope that's good enough.


Note You need to log in before you can comment on or make changes to this bug.