Bug 430788 - Exception listeners are not implemented.
Exception listeners are not implemented.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
beta
All Linux
urgent Severity high
: ---
: ---
Assigned To: Rafael H. Schloming
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 14:16 EST by Alan Conway
Modified: 2014-12-01 18:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 11:35:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-01-29 14:16:10 EST
Description of problem:

Customer wants to use setExceptionListener and onException method to implement
re-connect logic after getting an exception indicating the connection with the
broker has disconnected. I am able to receive messages OK, but when I do
"service rhmd stop" the onException method is not called. The program continues
to run, and gives no indication that the connection is closed. Should stopping
the broker cause onException to be called in my program? Is there any other way
to close the connection and test the re-connect logic?

The exception handler must deal with orderly and disorderly disconnects, e.g.
due to broker crash, network failure etc.
Comment 1 Rajith Attapattu 2008-01-29 17:40:37 EST
The exceptions were not propogated properly to the JMS Layer (not implemented).
I have fixed that in Apache Qpid trunk rev 616542.

We also need to detect a network connection drop and notify the qpid layer, so
it can be passed to the JMS layer. This is also not implemented yet.
Comment 2 Mike Bonnet 2008-02-29 11:43:08 EST
qpid-java-common-0.2-9 and qpid-java-client-0.2-9 have been pushed to the staging repo for testing

Note You need to log in before you can comment on or make changes to this bug.