Bug 43080 - mod_bandwidth breaks POSTs to Action/AddHandler cgis
mod_bandwidth breaks POSTs to Action/AddHandler cgis
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-31 12:23 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:47:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-31 12:23:45 EDT
Description of Problem:
If mod_bandwidth is loaded as a module, even if it is not used, it will cause   none of the html form POST data to be passed on the STDIN to the cgi which is   called using the Action/AddHandler configs. This will prevent PHP from          receiving form POST data if it is run as a cgi instead of as a module.


How Reproducible: every time


Steps to Reproduce:
1.
Make sure that mod_bandwidth is loaded:
LoadModule bandwidth_module   modules/mod_bandwidth.so
AddModule mod_bandwidth.c
2.
Set up a handler.
Action test-script /cgi-bin/form.cgi
AddHandler test-script .testcgi
3.
Create a form.cgi script such as:
------------
#!/bin/bash
echo "content-type: text/plain"
echo
env
echo "---- STDIN ----"
cat
---------------

4. Create a file with the extension that will trigger the handler, such as junk.testcgi. It doesn't matter what's in the file, since we won't be processing it.

5. Create a form to post to junk.testcgi.

------- test.html ---------
<form action=junk.testcgi method=POST>
<input type=text name=MYVAR value="foo">
<input type=submit value=submit>
</form>
--------------------------


Actual Results:
 Now when you go to this form and submit it, it will not show any information below the "------STDIN-----" line in form.cgi. 

Expected Results:
It should show the post data below the "-------STDIN--------" line.

Additional Information:
	
If you change the form to containt "action=/cgi-bin/form.cgi", the data will be correctly passed to the cgi, so that it will print out the post vars below the  "-------STDIN------" line. Therefore, it is just a problem with the Action/     AddHandler configs and mod_bandwidth.
Comment 1 Joe Orton 2004-09-21 06:47:45 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.