Bug 430822 - Change Component 'yum-software-management' to 'software-management-guide'
Change Component 'yum-software-management' to 'software-management-guide'
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: software-management-guide (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: David Lawrence
Paul W. Frields
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 18:10 EST by eric@christensenplace.us
Modified: 2008-02-22 15:45 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 15:45:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add software-management-guide component (1.20 KB, patch)
2008-02-05 17:57 EST, Karsten Wade
no flags Details | Diff

  None (edit)
Description eric@christensenplace.us 2008-01-29 18:10:02 EST
Respectfully request Fedora Document component 'yum-software-management' be
changed to 'software-management-guide' as the document has morphed into this. 
Also, request that I be made the default "assigned to" person for these tickets.

Thank you!
Comment 1 David Lawrence 2008-01-29 22:26:20 EST
Changing to proper product/component so the right person can address this issue.
Comment 2 Karsten Wade 2008-02-05 17:56:20 EST
OK, I may have mis-read David's message that I had to do the task, rather than
address it back here.

Talking around, it sounds like the thing we want is to have the component name
changed in the database.  We want old bugs to follow the new component name,
even though there aren't (m)any.  It would be good to not pollute the namespace
with an old unmaintained name.

I made an update in /cvs/docs/owners/owners.list to add this new component
(software-management-guide) with Eric as the maintainer.  I haven't committed
those changes because I don't want to mess anything up.  The entry is in a patch
I'll attach to this report.  Note that I did not erase the entry for
yum-software-management in that patch.

Dave -- would you changing this directly in the db be the best thing?

Comment 3 Karsten Wade 2008-02-05 17:57:18 EST
Oops, forgot to add dkl to the Cc:

Dave - please check this report for comment #2 for you.

thx
Comment 4 Karsten Wade 2008-02-05 17:57:36 EST
Created attachment 294057 [details]
patch to add software-management-guide component
Comment 5 Karsten Wade 2008-02-21 23:49:23 EST
Reassigning.

Dave -- asking around, it sounds as if what we need is for a bugzilla maintainer
to change the component name.

Should I load the proper details in to /cvs/docs/owners/owners.list?  I didn't
want to commit the changes without knowing if that was the right thing to do.

thx - Karsten
Comment 6 David Lawrence 2008-02-22 10:48:17 EST
(In reply to comment #5)
> Reassigning.
> 
> Dave -- asking around, it sounds as if what we need is for a bugzilla maintainer
> to change the component name.
> 
> Should I load the proper details in to /cvs/docs/owners/owners.list?  I didn't
> want to commit the changes without knowing if that was the right thing to do.
> 
> thx - Karsten

Normally the Fedora Infrastructure team handles all component
adding/editing/removing for the Fedora product in Bugzilla via XMLRPC calls. I
would not be able to comment on the owners.list file myself as I am not involved
with that side of things. I can manually change the component information
throught the UI if you want but their automation may come and change it back if
it is not updated on their end.

Let me know what I need to do
Dave
Comment 7 Toshio Ernie Kuratomi 2008-02-22 15:23:22 EST
I don't know of an xmlrpc call that can rename a component.  If there is, I can
make use of it :-)

I think that Karsten understands how docs/owners/owners.list works... he just
needs to coordinate how to go about renaming the product so that it carries all
old bugs over.  Should he commit the changes to owners.list, wait for it to be
created by the Fedora docs scripts, and then have you move the bugs and remove
the outdated component?  Or should he setup a time when you perform a rename of
the component and then he commits the changes to owners.list right afterwards?
Comment 8 David Lawrence 2008-02-22 15:41:30 EST
(In reply to comment #7)
> I don't know of an xmlrpc call that can rename a component.  If there is, I can
> make use of it :-)
> 
> I think that Karsten understands how docs/owners/owners.list works... he just
> needs to coordinate how to go about renaming the product so that it carries all
> old bugs over.  Should he commit the changes to owners.list, wait for it to be
> created by the Fedora docs scripts, and then have you move the bugs and remove
> the outdated component?  Or should he setup a time when you perform a rename of
> the component and then he commits the changes to owners.list right afterwards?

No the XMLRPC API does not allow for changing of component name yet. This is
planned for 3.2 upgrade in the near future.

I can change the component name through the web UI which will leave all of the
bugs attached to the new name since they are referenced on the back end by ID
and not by name.

I will go ahead and do this.

Dave
Comment 9 David Lawrence 2008-02-22 15:45:48 EST
I have update the name and changed the default owner to
eric@christensenplace.us/kwade@redhat.com for any new bugs. To move the old bugs
over to the new owner please use the mass-edit feature of buglist.cgi.

Dave

Note You need to log in before you can comment on or make changes to this bug.