Bug 430834 - sane-backends has a dependency on libsane-hpaio
sane-backends has a dependency on libsane-hpaio
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 19:37 EST by Joseph A. Farmer
Modified: 2009-12-31 10:34 EST (History)
1 user (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 00:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph A. Farmer 2008-01-29 19:37:17 EST
Description of problem: xsane has a dependency on hplip.


Version-Release number of selected component (if applicable):
Fedora 8.

How reproducible:
Linked every time. 

Steps to Reproduce:
1. Install xsane
2. hplip comes along for the ride.
3.
  
Actual results:
yum install xsane gets me:
Installing:
 xsane                   i386       0.994-4.fc8      fedora            2.0 M
Installing for dependencies:
 hpijs                   i386       1:2.7.12-4.fc8   updates           328 k
 hplip                   i386       2.7.12-4.fc8     updates           9.8 M
 libsane-hpaio           i386       2.7.12-4.fc8     updates            57 k
 net-snmp                i386       1:5.4.1-5.fc8    updates           698 k
 sane-backends           i386       1.0.18-17.fc8    fedora            1.0 M
 sane-backends-libs      i386       1.0.18-17.fc8    fedora            2.3 M

Expected results:
Only sane stuff should be installed.

Additional info:
I was going to do a yum update.  I noticed that 9mb of that was going to be
hplip.  I don't have an HP printer, scanner, anything.  So, not wanting to waste
the bandwidth, I first did a yum remove hplip.  Bye bye sane.

Maybe sane must be linked to hplip?  If not that should be removed.  I have a
cheap non-HP scanner and don't really want the HP stuff if I don't need it.  It
just wastes yum update bandwidth for mirrors.

Not a big deal.  Just think that dependency should be removed if possible.
Comment 1 Nils Philippsen 2008-01-30 06:23:46 EST
I'm building sane-backends-1.0.18-21.fc9 in Rawhide now with the dependency
removed. Future updates in the stable Fedora versions should pick that up.
Comment 2 Joseph A. Farmer 2008-05-22 00:01:22 EDT
Works in Fedora 9.  Removed both HP packages and it didn't nuke xsane.  Thank
you.  My bandwidth provider thanks you too.
Comment 3 Kevin Kofler 2009-12-23 09:34:47 EST
IMHO this is completely broken. Now HP scanners don't work out of the box anymore.
Comment 4 Nils Philippsen 2009-12-28 07:15:36 EST
(In reply to comment #3)
> IMHO this is completely broken. Now HP scanners don't work out of the box
> anymore.  

Details?
Comment 5 Kevin Kofler 2009-12-30 13:32:40 EST
The details are that one has to install the libsane-hpaio package by hand these days because there is nothing dragging it in anymore. (The printer drivers are not installed by default anymore because CUPS now has PackageKit integration (which didn't work in KDE last I checked, but that's a separate issue), but SANE has no such thing.) But if you think that's OK, I'll just shut up.
Comment 6 Nils Philippsen 2009-12-31 06:38:39 EST
I'm not sure there's an ideal solution, at least I don't see one right now. If somebody installs the "Graphics" group (during installation or with "yum groupinstall"), then libsane-hpaio is installed. But if somebody only installs the sane-backends package, libsane-hpaio doesn't get installed and in that case a device needing that won't work. Adding the requirement back to the sane-backends package is only a band-aid -- it was removed for a purpose, i.e. so that people can cleanly get rid of libsane-hpaio (which has substantially large other dependencies) if they don't have such a device.

X11 drivers are in a similar situation -- only because the "xorg-x11-drivers" meta package (which requires all other driver packages) is always installed does all graphics hardware work out of the box. The difference is that most people simply install the "X Window System" group during installation and not a subset of individual packages afterwards.

A possible solution could be a soft dependency on libsane-hpaio (once RPM has this feature), or if there where a generic way by which the system (udev in conjunction with PackageKit?) would autonomously install driver packages necessary for installed hardware.

If you have another idea how to tackle this, I'm all ears ;-).
Comment 7 Joseph A. Farmer 2009-12-31 10:34:29 EST
(In reply to comment #6)
> I'm not sure there's an ideal solution, at least I don't see one right now. If
> somebody installs the "Graphics" group (during installation or with "yum
> groupinstall"), then libsane-hpaio is installed. But if somebody only installs
> the sane-backends package, libsane-hpaio doesn't get installed and in that case
> a device needing that won't work. Adding the requirement back to the
> sane-backends package is only a band-aid -- it was removed for a purpose, i.e.
> so that people can cleanly get rid of libsane-hpaio (which has substantially
> large other dependencies) if they don't have such a device.
> 
> X11 drivers are in a similar situation -- only because the "xorg-x11-drivers"
> meta package (which requires all other driver packages) is always installed
> does all graphics hardware work out of the box. The difference is that most
> people simply install the "X Window System" group during installation and not a
> subset of individual packages afterwards.
> 
> A possible solution could be a soft dependency on libsane-hpaio (once RPM has
> this feature), or if there where a generic way by which the system (udev in
> conjunction with PackageKit?) would autonomously install driver packages
> necessary for installed hardware.
> 
> If you have another idea how to tackle this, I'm all ears ;-).  

You make a good point about the xorg drivers.  The machines I have came with integrated Intel graphics but, wanting dual monitors, I installed Radeons.  The driver package for Radeons already existed so I didn't need to install that.  There is value in that.  Yes, I'm aware of the Vesa driver.

Anyway, if it makes his hardware work, just bundle it in.  Having hardware work is probably better than permitting the removal of unneeded packages.

So there really isn't a good solution so go with the solution which results in working hardware.

Cheers.

Note You need to log in before you can comment on or make changes to this bug.